summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-01-14 14:36:15 +0800
committerSam James <sam@gentoo.org>2023-01-14 19:14:40 +0000
commit587af81f3bb5a65be695401fc1b331eb88808c59 (patch)
tree52d4ff6968ffcf9fcd3da5ab48e4b0d3ff90821a
parentapp-crypt/rhash: fix build with lld-16 (diff)
downloadgentoo-587af81f3bb5a65be695401fc1b331eb88808c59.tar.gz
gentoo-587af81f3bb5a65be695401fc1b331eb88808c59.tar.bz2
gentoo-587af81f3bb5a65be695401fc1b331eb88808c59.zip
net-dns/libidn2: fix build with lld-16
Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/29097 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-dns/libidn2/libidn2-2.3.4.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-dns/libidn2/libidn2-2.3.4.ebuild b/net-dns/libidn2/libidn2-2.3.4.ebuild
index abe76b1078f5..7f65dd252bed 100644
--- a/net-dns/libidn2/libidn2-2.3.4.ebuild
+++ b/net-dns/libidn2/libidn2-2.3.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal toolchain-funcs verify-sig
+inherit flag-o-matic multilib-minimal toolchain-funcs verify-sig
DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
HOMEPAGE="
@@ -37,6 +37,13 @@ BDEPEND="
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libidn.asc
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myconf=(
CC_FOR_BUILD="$(tc-getBUILD_CC)"
$(use_enable static-libs static)