summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-12 06:21:38 +0000
committerSam James <sam@gentoo.org>2023-01-12 07:06:02 +0000
commit28587a7ad4569a4f56a0fb204497da7b9b6a7642 (patch)
treed33b3e9b80463646cb351a1fc47e5be6ec8657c3
parentdev-python/xkbcommon: new package, add 0.8 (diff)
downloadgentoo-28587a7ad4569a4f56a0fb204497da7b9b6a7642.tar.gz
gentoo-28587a7ad4569a4f56a0fb204497da7b9b6a7642.tar.bz2
gentoo-28587a7ad4569a4f56a0fb204497da7b9b6a7642.zip
dev-python/pywlroots: new package, add 0.15.24
Bug: https://bugs.gentoo.org/846380 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pywlroots/Manifest1
-rw-r--r--dev-python/pywlroots/files/pywlroots-0.15.24-no-import-version-check.patch13
-rw-r--r--dev-python/pywlroots/metadata.xml11
-rw-r--r--dev-python/pywlroots/pywlroots-0.15.24.ebuild44
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pywlroots/Manifest b/dev-python/pywlroots/Manifest
new file mode 100644
index 000000000000..42da54f56046
--- /dev/null
+++ b/dev-python/pywlroots/Manifest
@@ -0,0 +1 @@
+DIST pywlroots-0.15.24.gh.tar.gz 85570 BLAKE2B 0c7ba0be6159152488785298028bb1feec20e2380357060a850dab417b3fb1fccb4a9e6cc6564d2b7f124bf4fc454789549267e9036b0b4559e5fcd4c6f06196 SHA512 b29b76cf18a65b2ef19d15ecf018a9ba44119d60ee61435967d17f06d5f7544d2117f2e9a81574734c71591a237b00c8584a5cc6d6adb928f39f11170f21ee94
diff --git a/dev-python/pywlroots/files/pywlroots-0.15.24-no-import-version-check.patch b/dev-python/pywlroots/files/pywlroots-0.15.24-no-import-version-check.patch
new file mode 100644
index 000000000000..eb0cce91ac35
--- /dev/null
+++ b/dev-python/pywlroots/files/pywlroots-0.15.24-no-import-version-check.patch
@@ -0,0 +1,13 @@
+https://github.com/flacjacket/gentoo-overlay/blob/master/dev-python/pywlroots/files/pywlroots-no_version_check.patch
+
+This causes sandbox failures in e.g. qtile on importing pywlroots.
+--- a/wlroots/ffi_build.py
++++ b/wlroots/ffi_build.py
+@@ -44,6 +44,7 @@ def load_wlroots_version():
+
+ def check_version():
+ """Check for wlroots version compatibility"""
++ return
+ # When importing a system-level installed package, we may not be able to
+ # create neighboring files, which is done by the `.verify` step. If this
+ # error is hit, we check with the compiled `wlroots.lib`.
diff --git a/dev-python/pywlroots/metadata.xml b/dev-python/pywlroots/metadata.xml
new file mode 100644
index 000000000000..34ba1c191606
--- /dev/null
+++ b/dev-python/pywlroots/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">flacjacket/pywlroots</remote-id>
+ <remote-id type="pypi">pywlroots</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pywlroots/pywlroots-0.15.24.ebuild b/dev-python/pywlroots/pywlroots-0.15.24.ebuild
new file mode 100644
index 000000000000..5bd07ae0e059
--- /dev/null
+++ b/dev-python/pywlroots/pywlroots-0.15.24.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding to the wlroots library using cffi"
+HOMEPAGE="
+ https://github.com/flacjacket/pywlroots
+ https://pypi.org/project/pywlroots/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywlroots/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# See README for wlroots dep
+RDEPEND="
+ >=dev-python/pywayland-0.4.14[${PYTHON_USEDEP}]
+ >=dev-python/xkbcommon-0.2[${PYTHON_USEDEP}]
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.24-no-import-version-check.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ # No die deliberately as sometimes it doesn't exist
+ rm -r wlroots
+
+ epytest
+}