summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-13 09:55:26 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-13 10:22:15 +0300
commit1bf50f028c928c180b32a4227fee6a8740e0c832 (patch)
treef0edf89140d690acc9a25a89dc0e846d575545db
parentdev-util/mingw64-toolchain: fix direct objdump call (diff)
downloadgentoo-1bf50f028c928c180b32a4227fee6a8740e0c832.tar.gz
gentoo-1bf50f028c928c180b32a4227fee6a8740e0c832.tar.bz2
gentoo-1bf50f028c928c180b32a4227fee6a8740e0c832.zip
dev-python/greenstalk: Use PEP517 build
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/greenstalk/greenstalk-2.0.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/greenstalk/greenstalk-2.0.0-r1.ebuild b/dev-python/greenstalk/greenstalk-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..3bf1819cb945
--- /dev/null
+++ b/dev-python/greenstalk/greenstalk-2.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python 3 client for the beanstalkd work queue"
+HOMEPAGE="https://greenstalk.readthedocs.io/ https://github.com/justinmayhew/greenstalk"
+SRC_URI="
+ https://github.com/justinmayhew/greenstalk/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( app-misc/beanstalkd )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}