summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-24 07:10:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-24 08:10:42 +0200
commit19d2eecb447cd44eaff1cc8cadb5c4e17dd66fac (patch)
tree77bf6a12a660ebd0859681a31b68b73b4f8cf405
parentdev-python/jsonschema-specifications: Bump to 2023.6.1 (diff)
downloadgentoo-19d2eecb447cd44eaff1cc8cadb5c4e17dd66fac.tar.gz
gentoo-19d2eecb447cd44eaff1cc8cadb5c4e17dd66fac.tar.bz2
gentoo-19d2eecb447cd44eaff1cc8cadb5c4e17dd66fac.zip
dev-python/pip-run: Bump to 12.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pip-run/Manifest1
-rw-r--r--dev-python/pip-run/pip-run-12.0.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index 64cfa6b54844..3682836d3c08 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -2,3 +2,4 @@ DIST pip-run-10.0.7.tar.gz 32869 BLAKE2B ea5dfea09def536eced9436a114f12cbefccf26
DIST pip-run-10.1.1.tar.gz 33010 BLAKE2B 5a3dcd1e119b65718b465ecbd118d80de776252ecbd438344eb78abc2e4a69073417310ed096f0b604740762aa24af2788041476c93d919ea72812e1597327f5 SHA512 ddf61aa31012567ff21e943739a1e29066875db3c39ca77abfa409fd75abc599756ca8aeaf9bd23d19af46ad2747e7dec4a7d3cf76a444f59c19e769419dc59a
DIST pip-run-10.2.0.tar.gz 33523 BLAKE2B 7d19c089da98dbba2faec969f490fcd5ea48881f4ccbbfaa283465ef083521aee7d82b9de8b03a89ec8b08005db1232cd9577030cb98c111b4a0e0f7294cca84 SHA512 b26a00c6ebd8e9e505e6b218fea7070b23b5926de44e1d5a762abb2a4ebd62b1bdda7e19c4092012daf068b518a2e127ab08099f6d1a7ddc643b3ba5bf999ed0
DIST pip-run-11.0.0.tar.gz 33598 BLAKE2B 3951c6cf959e137aeec2acae17eb6fd9b63a1716f1fe8cac55c964cf6cd975d5085dc8e05f11f00b3dd404d8f12d351d0e3f9cdd486cf1a883f917e60ad91103 SHA512 3b6c3aee3bf340f6a18e3f0acda56ed6da00dc21054e9a20499151c89a44ca388611bb7df57f04fa9b580dacd65a26c9cc34589bc01638f7ac1cc6f1752e2e5b
+DIST pip-run-12.0.0.tar.gz 34473 BLAKE2B e0a25cf4698979b22cd714f3326497d3381cc9b6c8be84085dbb239ada13f8a57b1b88a6ffde7d0fec4c58ec790c2287379c8f6843c6d20104450c1c9860f0b3 SHA512 efac5a3faaa48480b68b38a8a13e9407390fd96fff505228fe8482bbc9b4f12a7b2ad33b7abb9931a7fbd3d694d996fe58e87a4afa26f800c6e749b70c397d9b
diff --git a/dev-python/pip-run/pip-run-12.0.0.ebuild b/dev-python/pip-run/pip-run-12.0.0.ebuild
new file mode 100644
index 000000000000..f8ff3d17710e
--- /dev/null
+++ b/dev-python/pip-run/pip-run-12.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-env[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.7[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+
+ if ! has_version "dev-python/nbformat[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_scripts.py
+ )
+ fi
+
+ epytest -m "not network"
+}