summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 04:56:12 +0100
committerSam James <sam@gentoo.org>2021-07-31 23:13:44 +0100
commit06b4e98a3a540349da8614201a875c5607fbbab7 (patch)
tree56b1781590cb1962c44ccb2307a6a919866185e2
parentsys-fs/udisks: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-06b4e98a3a540349da8614201a875c5607fbbab7.tar.gz
gentoo-06b4e98a3a540349da8614201a875c5607fbbab7.tar.bz2
gentoo-06b4e98a3a540349da8614201a875c5607fbbab7.zip
app-admin/puppet: [QA] use systemd.eclass to install unit files
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-admin/puppet/puppet-5.5.22-r1.ebuild5
-rw-r--r--app-admin/puppet/puppet-7.8.0-r1.ebuild5
-rw-r--r--app-admin/puppet/puppet-7.9.0-r1.ebuild5
3 files changed, 6 insertions, 9 deletions
diff --git a/app-admin/puppet/puppet-5.5.22-r1.ebuild b/app-admin/puppet/puppet-5.5.22-r1.ebuild
index a33a8285cc88..3fc2f8062ec5 100644
--- a/app-admin/puppet/puppet-5.5.22-r1.ebuild
+++ b/app-admin/puppet/puppet-5.5.22-r1.ebuild
@@ -11,7 +11,7 @@ RUBY_FAKEGEM_TASK_DOC="doc:all"
RUBY_FAKEGEM_EXTRAINSTALL="locales"
-inherit ruby-fakegem tmpfiles
+inherit ruby-fakegem systemd tmpfiles
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
@@ -84,8 +84,7 @@ all_ruby_install() {
all_fakegem_install
# systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+ systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
# tmpfiles stuff
newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"
diff --git a/app-admin/puppet/puppet-7.8.0-r1.ebuild b/app-admin/puppet/puppet-7.8.0-r1.ebuild
index 9c67dbe4f524..f2b79f3d4dc9 100644
--- a/app-admin/puppet/puppet-7.8.0-r1.ebuild
+++ b/app-admin/puppet/puppet-7.8.0-r1.ebuild
@@ -8,7 +8,7 @@ RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC="doc:all"
RUBY_FAKEGEM_EXTRAINSTALL="locales"
-inherit ruby-fakegem tmpfiles
+inherit ruby-fakegem systemd tmpfiles
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
@@ -81,8 +81,7 @@ all_ruby_install() {
all_fakegem_install
# systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+ systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
# tmpfiles stuff
newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"
diff --git a/app-admin/puppet/puppet-7.9.0-r1.ebuild b/app-admin/puppet/puppet-7.9.0-r1.ebuild
index b097feb026ad..c1c0ce4f6d0c 100644
--- a/app-admin/puppet/puppet-7.9.0-r1.ebuild
+++ b/app-admin/puppet/puppet-7.9.0-r1.ebuild
@@ -8,7 +8,7 @@ RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC="doc:all"
RUBY_FAKEGEM_EXTRAINSTALL="locales"
-inherit ruby-fakegem tmpfiles
+inherit ruby-fakegem systemd tmpfiles
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
@@ -81,8 +81,7 @@ all_ruby_install() {
all_fakegem_install
# systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+ systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
# tmpfiles stuff
newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"