aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/praat/Manifest2
-rw-r--r--sci-misc/praat/praat-6.1.40.ebuild36
-rw-r--r--sci-misc/praat/praat-6.1.42.ebuild60
3 files changed, 61 insertions, 37 deletions
diff --git a/sci-misc/praat/Manifest b/sci-misc/praat/Manifest
index a70351bb7..552567989 100644
--- a/sci-misc/praat/Manifest
+++ b/sci-misc/praat/Manifest
@@ -1 +1 @@
-DIST praat-6.1.40.tar.gz 33612192 BLAKE2B 0515acf011cd7b365bc02bbe373bc7131d67edfca18bae1f6d59d9ef40969dfb3e4d90a6905b02ded7bdef39d5d300b310c2540d5e8357a2dde3af26bf953086 SHA512 7e1e02fdc8dd800c5aadee1823581b27d96fc4fa3f255d5bc91e21b2e2756db41ffb2d44d6b3b0a4951f0b40ff0ec03300a4f271dc9969ce4c45c42bd3b09dff
+DIST praat-6.1.42.tar.gz 33628783 BLAKE2B b406ae2d0242c3a093a99db45a083cf54180be6632946596e5b3cebf20b133e29fcac5081f5fc997cf6b6c313128b4f2813b00c2b096fc5c085c8be1642cc6c7 SHA512 eb3f6b5f0a74a1eba4dd4fb6f9231322e2accf127e8d9e104066c4341120e72c00f3773b38636891094d9912dd4081e2b6719f1c07883e592341dbb81f2db9ce
diff --git a/sci-misc/praat/praat-6.1.40.ebuild b/sci-misc/praat/praat-6.1.40.ebuild
deleted file mode 100644
index 3e7f7d95c..000000000
--- a/sci-misc/praat/praat-6.1.40.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Speech analysis and synthesis"
-HOMEPAGE="https://www.fon.hum.uva.nl/praat/ https://github.com/praat/praat"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="GPL-2"
-SLOT="0"
-
-DEPEND="
- x11-libs/gtk+:2
- media-libs/alsa-lib
- media-sound/pulseaudio"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- # TODO: following line should be updated for non-linux etc. builds
- # (Flammie does not have testing equipment)
- cp makefiles/makefile.defs.linux.pulse makefile.defs || die
-
- cat <<-EOF >> makefile.defs
- CFLAGS += ${CFLAGS}
- CXXFLAGS += ${CXXFLAGS}
- EOF
-}
-
-src_install() {
- dobin ${PN}
- insinto /usr/share/${PN}
- doins -r test
-}
diff --git a/sci-misc/praat/praat-6.1.42.ebuild b/sci-misc/praat/praat-6.1.42.ebuild
new file mode 100644
index 000000000..5a60b5149
--- /dev/null
+++ b/sci-misc/praat/praat-6.1.42.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Speech analysis and synthesis"
+SRC_URI="https://github.com/praat/praat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://www.fon.hum.uva.nl/praat/"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="+pulseaudio static-libs +X"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ pulseaudio? ( media-sound/pulseaudio )
+ static-libs? ( media-libs/alsa-lib )
+ X? ( x11-libs/gtk+:3 )
+ !X? ( x11-libs/pango )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/praat-${PV}"
+
+src_prepare() {
+ if use X; then
+ if use static-libs; then
+ if use pulseaudio; then
+ cp "${S}/makefiles/makefile.defs.linux.pulse_static" "${S}/makefile.defs"
+ else
+ cp "${S}/makefiles/makefile.defs.linux.alsa" "${S}/makefile.defs"
+ fi
+ else
+ if use pulseaudio; then
+ cp "${S}/makefiles/makefile.defs.linux.pulse" "${S}/makefile.defs"
+ else
+ cp "${S}/makefiles/makefile.defs.linux.silent" "${S}/makefile.defs"
+ fi
+ fi
+ else
+ cp "${S}/makefiles/makefile.defs.linux.nogui" "${S}/makefile.defs"
+ fi
+ cat <<-EOF >> makefile.defs
+ CFLAGS += ${CFLAGS}
+ LDFLAGS += ${LDFLAGS}
+ CXXFLAGS += ${CXXFLAGS}
+ EOF
+ default
+}
+
+src_install() {
+ if [ -e praat_nogui ]; then
+ mv praat_nogui praat
+ elif [ -e praat_static ]; then
+ mv praat_static praat
+ fi
+ dobin praat
+ insinto /usr/share/${PN}/test
+ doins -r test/*
+}