aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/half/half-2.1.0.ebuild')
-rw-r--r--dev-libs/half/half-2.1.0.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/dev-libs/half/half-2.1.0.ebuild b/dev-libs/half/half-2.1.0.ebuild
index 588ee7e94..023316aab 100644
--- a/dev-libs/half/half-2.1.0.ebuild
+++ b/dev-libs/half/half-2.1.0.ebuild
@@ -1,24 +1,20 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit unpacker
+EAPI=7
DESCRIPTION="Half-precision floating-point library"
HOMEPAGE="http://half.sourceforge.net/"
-SRC_URI="https://downloads.sourceforge.net/project/half/half/${PV}/half-${PV}.zip"
+SRC_URI="https://downloads.sourceforge.net/project/half/half/${PV}/${P}.zip"
+S="${WORKDIR}"
LICENSE="MIT"
KEYWORDS="~amd64"
SLOT="0"
-DEPEND="app-arch/unzip"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"
+BDEPEND="app-arch/unzip"
src_install() {
- insinto /usr/include
- doins include/half.hpp
+ cd include
+ doheader half.hpp
}