aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/hepunits/Manifest1
-rw-r--r--sci-physics/hepunits/hepunits-2.3.5.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/sci-physics/hepunits/Manifest b/sci-physics/hepunits/Manifest
index 9b6a3c900..4bd461fd8 100644
--- a/sci-physics/hepunits/Manifest
+++ b/sci-physics/hepunits/Manifest
@@ -1,2 +1,3 @@
DIST hepunits-2.3.2.tar.gz 13327 BLAKE2B 16986f4cf96eb927e5ae7268dc2975957846678bff0569fc5d5b9d36bb5dae251905283a07e5fcdd895b20982e1e2d32bce5048752d654ca085286e89b65837f SHA512 48d0a4939e19fc6f26b3bb5f8515d8e0d9d4cbed172c14ae30609c2039bdb77625dad8e1e628178481ee0f203d7d36cd2e0d3306f3b344fe14cd68827c4d9477
DIST hepunits-2.3.3.tar.gz 13491 BLAKE2B ec212be4e53e7ea5aa195852ea6ad4f3aac8e3eb49676e6bef76d525be861ecd4480821b248d746950b45affccd31bf23d5232aee13058bb48ec8d76c4f70a14 SHA512 7a29dd6220c1fbe610f15ef66f02e499d7e2ade8c39827e3229ae74035d127ca7805b9e32c3859c5af4b001725d21514fd81f0408d7f0dc76e9ee34aa66191e8
+DIST hepunits-2.3.5.tar.gz 13537 BLAKE2B 57a2e06e5619d6ff90f6a29f11359aa36418c959ee336e40b21ad2ce054cbb381ed75da2f4f973439a0306e37a01481b65374c3e24a1b9ba24063e34c5b71aad SHA512 de63fd24a87ca52b74e46ee74638663a8d83ee352aaf7b8bf84710681c3753a741f30ceb683f0d042c6806fb6b48b92fc80c861195ba9685fe9d60784bf94882
diff --git a/sci-physics/hepunits/hepunits-2.3.5.ebuild b/sci-physics/hepunits/hepunits-2.3.5.ebuild
new file mode 100644
index 000000000..b2f76d1d1
--- /dev/null
+++ b/sci-physics/hepunits/hepunits-2.3.5.ebuild
@@ -0,0 +1,23 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1
+
+DESCRIPTION="units and constants in the HEP system of units"
+HOMEPAGE="https://github.com/scikit-hep/hepunits"
+
+LICENSE="BSD"
+SLOT="0"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scikit-hep/hepunits"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+
+BDEPEND="dev-python/hatch-vcs[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest