aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bigaouette <nbigaouette@gmail.com>2012-04-28 11:04:38 -0400
committerNicolas Bigaouette <nbigaouette@gmail.com>2012-04-28 11:06:45 -0400
commit05deda75a8f8db36c127d533d59990b384e27b73 (patch)
tree91ff3f6a941ea13461d472c7c3f97b06f3d4d72c /sys-devel/gdebugger/gdebugger-6.2.438.ebuild
parentmask =sci-libs/mmdb-1.24.20111208, no pkg-confiles installed (diff)
downloadsci-05deda75a8f8db36c127d533d59990b384e27b73.tar.gz
sci-05deda75a8f8db36c127d533d59990b384e27b73.tar.bz2
sci-05deda75a8f8db36c127d533d59990b384e27b73.zip
New ebuild: AMD gDEBugger version 6.2.438, an OpenCL and OpenGL debugger and memory analyzer.
Diffstat (limited to 'sys-devel/gdebugger/gdebugger-6.2.438.ebuild')
-rw-r--r--sys-devel/gdebugger/gdebugger-6.2.438.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/sys-devel/gdebugger/gdebugger-6.2.438.ebuild b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
new file mode 100644
index 000000000..36375d387
--- /dev/null
+++ b/sys-devel/gdebugger/gdebugger-6.2.438.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit versionator
+
+My_PN="gDEBugger"
+My_PV=$(delete_all_version_separators)
+
+DESCRIPTION="OpenCL and OpenGL debugger and memory analyzer."
+HOMEPAGE="http://developer.amd.com/tools/gDEBugger/Pages/default.aspx"
+
+if [[ "${ARCH}" == "amd64" ]]; then
+ _arch="x86_64"
+elif [[ "${ARCH}" == "x86" ]]; then
+ _arch="x86"
+fi
+
+SRC_URI="
+ x86? ( http://developer.amd.com/Downloads/AMD${My_PN}${PV}x86.tar.gz )
+ amd64? ( http://developer.amd.com/Downloads/AMD${My_PN}${PV}x86_64.tar.gz )"
+
+LICENSE="${My_PN}"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/libstdc++"
+DEPEND="${RDEPEND} app-text/html2text"
+
+RESTRICT="mirror strip"
+
+S="${WORKDIR}/${My_PN}${PV}-${_arch}"
+_destination=/opt/${My_PN}
+
+src_install() {
+ dodir /opt
+ dodir /usr/bin
+ dodir /usr/portage/licenses/
+ dodir /usr/share/applications
+
+ cd ..
+ cp -a ${S} ${D}${_destination}
+
+ # The included launcher gets the directory where it is being run; a symbolic
+ # link to it in /usr/bin thus cannot work. Instead, copy it to /usr/bin and
+ # remove the autodetection of the script's directory and hardcode it to ${_destination}.
+ # Then create a lowercase symbolic link to this new launcher.
+ cp ${D}${_destination}/${My_PN} ${D}/usr/bin/${My_PN}
+ sed "s|gDEBuggerBinariesDir=.*|gDEBuggerBinariesDir=\"${_destination}\"|g" -i ${D}/usr/bin/${My_PN}
+ dosym /usr/bin/${My_PN} /usr/bin/${PN}
+
+ html2text ${D}${_destination}/Legal/EndUserLicenseAgreement.htm > ${D}/usr/portage/licenses/${My_PN}.txt || die "Can't copy license"
+
+ echo "[Desktop Entry]
+Name=${My_PN}
+Exec=${_destination}/${My_PN}
+Type=Application
+GenericName=OpenCL/OpenGL debugger
+Terminal=false
+Icon=${My_PN}
+Caption=OpenCL/OpenGL debugger
+Categories=Application;Development;" > ${D}/usr/share/applications/${PN}.desktop || die "Can't create .desktop file"
+
+ insinto /usr/share/icons/hicolor/64x64/apps/
+ newins ${D}${_destination}/tutorial/images/applicationicon_64.png ${My_PN}.png
+}