aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-07-07 08:36:37 +0200
committerJustin Lecher <jlec@gentoo.org>2014-07-07 08:36:37 +0200
commit8b089a49addab2d4249ef31e8a4dd6f2d4bfa129 (patch)
tree0ee390c2a51f3d9d4ca6d18801e460858dd3ce1f /sci-physics
parentsci-chemistry/nmrpipe: Fix emul-linux deps for modern multilib (diff)
parentMerge pull request #236 from olifre/master (diff)
downloadsci-8b089a49addab2d4249ef31e8a4dd6f2d4bfa129.tar.gz
sci-8b089a49addab2d4249ef31e8a4dd6f2d4bfa129.tar.bz2
sci-8b089a49addab2d4249ef31e8a4dd6f2d4bfa129.zip
Merge remote-tracking branch 'github/master'
* github/master: dev-python/bokeh: dev-python/bokeh: New version with python3 support for bug #516052 dev-python/bokeh: dev-python/bokeh: Copy latest ebuild from portage Add subslot dependency on clhep, we need to rebuild for each clhep subslot change. New live ebuild for VGM, adapting to fixes for cmake install paths in upstream (no need to manually install in ebuild anymore). Released VGM-4.00 does not have these fixes yet, I am discussing with upstream whether they can also provide some tarballs of released versions (as sourceforge svn-snapshotting is unusable for us) and delay packaging of VGM-4.00 until then. New live ebuild, using cmake-buildsystem (upstream switches to cmake for next release), add flags for g4root and mtroot. Adapt to upstream's fixes concerning install paths, we don't need to do manually installation anymore. I will skip geant-vmc-3.00b01 from packaging, it does not include those fixes yet.
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/geant-vmc/ChangeLog8
-rw-r--r--sci-physics/geant-vmc/geant-vmc-9999.ebuild79
-rw-r--r--sci-physics/geant-vmc/metadata.xml3
-rw-r--r--sci-physics/vgm/ChangeLog10
-rw-r--r--sci-physics/vgm/vgm-3.06.ebuild2
-rw-r--r--sci-physics/vgm/vgm-9999.ebuild68
6 files changed, 169 insertions, 1 deletions
diff --git a/sci-physics/geant-vmc/ChangeLog b/sci-physics/geant-vmc/ChangeLog
index 353b8417e..807b464c9 100644
--- a/sci-physics/geant-vmc/ChangeLog
+++ b/sci-physics/geant-vmc/ChangeLog
@@ -2,6 +2,14 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*geant-vmc-9999 (06 Jul 2014)
+
+ 06 Jul 2014; Oliver Freyermuth <o.freyermuth@googlemail.com>
+ +geant-vmc-9999.ebuild, metadata.xml:
+ New live ebuild, using cmake-buildsystem (upstream switches to cmake for next
+ release), add flags for g4root and mtroot. Adapt to upstream's fixes
+ concerning install paths, we don't need to do manually installation anymore.
+
31 Mar 2014; Oliver Freyermuth <o.freyermuth@googlemail.com>
geant-vmc-3.1.15a.ebuild:
Fix syntax bug in dependency atom
diff --git a/sci-physics/geant-vmc/geant-vmc-9999.ebuild b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
new file mode 100644
index 000000000..fa8fa5592
--- /dev/null
+++ b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils versionator git-r3
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI=" http://root.cern.ch/git/geant4_vmc.git"
+ KEYWORDS=""
+else
+ MPV=$(get_version_component_range 2-)
+ SRC_URI="ftp://root.cern.ch/root/vmc/geant4_vmc.${MPV}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="http://root.cern.ch/root/vmc/VirtualMC.html"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="doc examples geant3 +g4root +mtroot vgm"
+
+RDEPEND="
+ sci-physics/root:=
+ >=sci-physics/geant-4.9.6[opengl,geant3?]
+ vgm? ( >=sci-physics/vgm-4.00 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use vgm Geant4VMC_USE_VGM)
+ $(cmake-utils_use geant3 Geant4VMC_USE_GEANT4_G3TOG4)
+ $(cmake-utils_use g4root Geant4VMC_USE_G4Root)
+ $(cmake-utils_use mtroot Geant4VMC_USE_MTRoot)
+ $(cmake-utils_use examples Geant4VMC_INSTALL_EXAMPLES)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ local dirs="g4root mtroot source"
+ use g4root && dirs+=" g4root "
+ use mtroot && dirs+=" mtroot "
+ use examples && dirs+=" examples "
+ local d
+ for d in ${dirs}; do
+ pushd ${d} > /dev/null || die
+ if use doc; then
+ doxygen || die
+ fi
+ popd > /dev/null
+ done
+}
+
+src_test() {
+ cd examples || die
+ local origDir=${CMAKE_USE_DIR}
+ CMAKE_USE_DIR=${CMAKE_USE_DIR}/examples
+ CMAKE_IN_SOURCE_BUILD=1
+ CMAKE_MODULE_PATH=../cmake
+ local mycmakeargs=(
+ -DCMAKE_MODULE_PATH=${origDir}/cmake
+ )
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ ./run_suite.sh || die
+ CMAKE_IN_SOURCE_BUILD=0
+ CMAKE_USE_DIR=$origDir
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README history version_number
+ use doc && dohtml -r Geant4VMC.html doc/*
+}
diff --git a/sci-physics/geant-vmc/metadata.xml b/sci-physics/geant-vmc/metadata.xml
index 1bbc127a3..828e0454c 100644
--- a/sci-physics/geant-vmc/metadata.xml
+++ b/sci-physics/geant-vmc/metadata.xml
@@ -15,5 +15,8 @@
</longdescription>
<use>
<flag name="vgm">Enable the Virtual Geometry Model (<pkg>sci-physics/vgm</pkg>)</flag>
+ <flag name="g4root">Build G4Root (interface for GEANT4 simulation with a ROOT geometry)</flag>
+ <flag name="geant3">Build with Geant4 G3toG4 library</flag>
+ <flag name="mtroot">Build MTRoot (provides ROOT IO manager classes with multi-threading support)</flag>
</use>
</pkgmetadata>
diff --git a/sci-physics/vgm/ChangeLog b/sci-physics/vgm/ChangeLog
index 78f7e21fc..5b5dce520 100644
--- a/sci-physics/vgm/ChangeLog
+++ b/sci-physics/vgm/ChangeLog
@@ -2,6 +2,16 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Jul 2014; Oliver Freyermuth <o.freyermuth@googlemail.com> vgm-3.06.ebuild:
+ Add subslot dependency on clhep, we need to rebuild for each clhep subslot
+ change.
+
+*vgm-9999 (06 Jul 2014)
+
+ 06 Jul 2014; Oliver Freyermuth <o.freyermuth@googlemail.com> +vgm-9999.ebuild:
+ New live ebuild for VGM, adapting to fixes for cmake install paths in upstream
+ (no need to manually install in ebuild anymore).
+
03 Apr 2014; Oliver Freyermuth <o.freyermuth@googlemail.com> vgm-3.06.ebuild:
Use zip-snapshot mirrored by jlec, sourceforge cannot automatically recreate
them and changes CRC each time
diff --git a/sci-physics/vgm/vgm-3.06.ebuild b/sci-physics/vgm/vgm-3.06.ebuild
index ccdc5a3d2..bd650c6e2 100644
--- a/sci-physics/vgm/vgm-3.06.ebuild
+++ b/sci-physics/vgm/vgm-3.06.ebuild
@@ -24,7 +24,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples +geant4 +root test xml"
RDEPEND="
- sci-physics/clhep
+ sci-physics/clhep:=
root? ( sci-physics/root:= )
geant4? ( >=sci-physics/geant-4.9.6[examples?] )
xml? ( dev-libs/xerces-c )"
diff --git a/sci-physics/vgm/vgm-9999.ebuild b/sci-physics/vgm/vgm-9999.ebuild
new file mode 100644
index 000000000..ddadd9970
--- /dev/null
+++ b/sci-physics/vgm/vgm-9999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils versionator subversion
+
+if [[ ${PV} == *9999* ]]; then
+ ESVN_REPO_URI="svn://svn.code.sf.net/p/vgm/code/trunk/vgm"
+ KEYWORDS=""
+else
+ # .zip-snapshot can be recreated by visiting
+ # http://sourceforge.net/p/${PN}/code/${COMMIT}/tarball?path=/tags/v$(replace_all_version_separators '-')
+ TAG_VER="${PN}-code-731-tags-v$(replace_all_version_separators '-')"
+ SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${TAG_VER}.zip"
+ S=${WORKDIR}/${TAG_VER}/${PN}
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Virtual Geometry Model for High Energy Physics Experiments"
+HOMEPAGE="http://ivana.home.cern.ch/ivana/VGM.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc examples +geant4 +root test xml"
+
+RDEPEND="
+ sci-physics/clhep:=
+ root? ( sci-physics/root:= )
+ geant4? ( >=sci-physics/geant-4.9.6 )
+ xml? ( dev-libs/xerces-c )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ test? ( geant4? ( xml? ( >=sci-physics/geant-4.9.6[gdml] ) ) )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLHEP_DIR="${EROOT}usr"
+ $(cmake-utils_use_with examples)
+ $(cmake-utils_use examples VGM_INSTALL_EXAMPLES)
+ $(cmake-utils_use_with geant4)
+ $(cmake-utils_use_with root)
+ $(cmake-utils_use_with test)
+ $(cmake-utils_use_with xml xercesc)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cd packages
+ doxygen || die
+ fi
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/test
+ ./test_suite.sh || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ cd doc || die
+ dodoc README todo.txt VGMhistory.txt VGM.html VGMversions.html
+ use doc && dohtml -r html/*
+}