aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-12 13:35:46 +0100
committerJustin Lecher <jlec@gentoo.org>2014-11-12 13:35:46 +0100
commit9b7147dbf2dc7d8919c1af5f65f893ec0f3d9256 (patch)
tree479b74a68a4c1a6ed7d5187cafe3b94f0cb695d8 /sci-misc/jwnl/jwnl-1.3_rc3.ebuild
parentsci-misc/finomaton: Bump to EAPI=5 (diff)
downloadsci-9b7147dbf2dc7d8919c1af5f65f893ec0f3d9256.tar.gz
sci-9b7147dbf2dc7d8919c1af5f65f893ec0f3d9256.tar.bz2
sci-9b7147dbf2dc7d8919c1af5f65f893ec0f3d9256.zip
sci-misc/jwnl: Bump to EAPI=5
Package-Manager: portage-2.2.14
Diffstat (limited to 'sci-misc/jwnl/jwnl-1.3_rc3.ebuild')
-rw-r--r--sci-misc/jwnl/jwnl-1.3_rc3.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sci-misc/jwnl/jwnl-1.3_rc3.ebuild b/sci-misc/jwnl/jwnl-1.3_rc3.ebuild
index 66b4877aa..aa2f66508 100644
--- a/sci-misc/jwnl/jwnl-1.3_rc3.ebuild
+++ b/sci-misc/jwnl/jwnl-1.3_rc3.ebuild
@@ -2,12 +2,16 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=5
+
inherit eutils java-pkg-2 java-utils-2 versionator
MY_P=${PN}$(delete_all_version_separators)
+
DESCRIPTION="Java interface to WordNet dictionary data"
HOMEPAGE="http://jwordnet.sf.net"
-SRC_URI="mirror://sourceforge/jwordnet/${MY_P}_src.zip
+SRC_URI="
+ mirror://sourceforge/jwordnet/${MY_P}_src.zip
mirror://sourceforge/jwordnet/${MY_P}.zip"
LICENSE="BSD"
@@ -23,9 +27,7 @@ RDEPEND=">=virtual/jre-1.4
S="${WORKDIR}"
-src_unpack() {
- cd "${S}"
- unpack ${A}
+src_prepare() {
rm -v commons-logging.jar jwnl.jar || die
}
@@ -39,7 +41,6 @@ src_compile() {
src_install() {
java-pkg_dojar ${PN}.jar utilities.jar
- dodir /usr/share/${PN}
insinto /usr/share/${PN}
doins create.sql database_properties.xml file_properties.xml \
jwnl_properties.dtd jwnl_properties.xsd map_properties.xml