aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald Weiner <harald.weiner@jku.at>2015-10-14 17:38:20 +0200
committerHarald Weiner <harald.weiner@jku.at>2015-10-15 18:36:22 +0200
commit300271cd1929ea46c443b25f741efca100d6c970 (patch)
tree428148dfdb93660124c8b7279e948ee81447d880 /sci-mathematics/gismo/gismo-0.8.1.ebuild
parentMerge pull request #515 from TheChymera/pysurfer (diff)
downloadsci-300271cd1929ea46c443b25f741efca100d6c970.tar.gz
sci-300271cd1929ea46c443b25f741efca100d6c970.tar.bz2
sci-300271cd1929ea46c443b25f741efca100d6c970.zip
added ebuild for gismo (Geometry+Simulation),
see https://gs.jku.at/gismo feedback from science-overlay-user(s) and more fixes
Diffstat (limited to 'sci-mathematics/gismo/gismo-0.8.1.ebuild')
-rw-r--r--sci-mathematics/gismo/gismo-0.8.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/gismo/gismo-0.8.1.ebuild b/sci-mathematics/gismo/gismo-0.8.1.ebuild
new file mode 100644
index 000000000..ff9f443d7
--- /dev/null
+++ b/sci-mathematics/gismo/gismo-0.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils eutils
+
+DESCRIPTION='C++ library for geometric design and numerical simulation'
+HOMEPAGE="https://gs.jku.at/gismo"
+SRC_URI="https://github.com/filiatra/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+# Unbundling in progress,
+# preparing local changes to get upstream
+
+src_prepare() {
+ epatch "${FILESDIR}/examples-CMakeLists.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use examples GISMO_BUILD_EXAMPLES)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ cd "${S}_build" || die "could not find cmake build folder"
+ emake doc
+}