aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-30 11:49:00 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-30 11:49:00 +0100
commit1e554b8b088f15c731c6a1254024ddc884dc9684 (patch)
tree3d6b67a802ddab0ca84d758381f0a4194faaa445 /sci-libs/wannier90
parentsci-libs/xblas: correct soname variable (diff)
downloadsci-1e554b8b088f15c731c6a1254024ddc884dc9684.tar.gz
sci-1e554b8b088f15c731c6a1254024ddc884dc9684.tar.bz2
sci-1e554b8b088f15c731c6a1254024ddc884dc9684.zip
sci-libs/wannier90: version bump, EAPI bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-libs/wannier90')
-rw-r--r--sci-libs/wannier90/Manifest3
-rw-r--r--sci-libs/wannier90/wannier90-2.0.1.1.ebuild77
-rw-r--r--sci-libs/wannier90/wannier90-3.1.0.ebuild (renamed from sci-libs/wannier90/wannier90-2.0.1.ebuild)31
3 files changed, 16 insertions, 95 deletions
diff --git a/sci-libs/wannier90/Manifest b/sci-libs/wannier90/Manifest
index d76ef415e..eb7675dee 100644
--- a/sci-libs/wannier90/Manifest
+++ b/sci-libs/wannier90/Manifest
@@ -1,2 +1 @@
-DIST wannier90-2.0.1.1.tar.gz 48721795 BLAKE2B 3f4307e6d8be2ff4c5595d776aab1c8ad80cac9cc730559f7ae7bb23dbd5320f27202252b4a7a4ec8dd8b11e1ece6a30ef4e99b7ea08a73257fcc45e43c2a50e SHA512 1522ee93314f265debe6d565d47007c591e2ee3d192fbe4ef05851aea49bce67398e16f5f59c384ddc3e2fc8660ce46d4bd48065789f09595a4c6166025622b7
-DIST wannier90-2.0.1.tar.gz 48327121 BLAKE2B ba077be65b7990c492b36bf0d385726f3f23ed3ac5442db3d1038788385fa5832d63da1c322aa7fd8fa9a4ee2ed1c55cda95d3bba97b1ba786488c7df1f544fe SHA512 dd7deb43272a9f0697ae59e272816a74ae15f7adb95f4c5d7ea40d98f8293b678da97494df471077a096f207d7a194a27ed09d6f456a8db20fe91e4f596602c4
+DIST wannier90-3.1.0.tar.gz 101211573 BLAKE2B 521caf8ee69b2381e518c276f0a8c6701a5bc57d8061a4106de740420cb4f9a5d7d509a01d700016d258ea0056e14a9aa30651f339c466528054909d0162ef48 SHA512 e31ea204210e9a3f719b5589e83410118eb9cd7dc331a4619df6d0a2a6d8ffb606e631dccd589dfe5334ae960c572a7289b77592d3a3d60fd464236f71ef1a18
diff --git a/sci-libs/wannier90/wannier90-2.0.1.1.ebuild b/sci-libs/wannier90/wannier90-2.0.1.1.ebuild
deleted file mode 100644
index bc7e9c399..000000000
--- a/sci-libs/wannier90/wannier90-2.0.1.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils eutils fortran-2 multilib toolchain-funcs
-
-DESCRIPTION="Calculates maximally localized Wannier functions (MLWFs)"
-HOMEPAGE="http://www.wannier.org/"
-#SRC_URI="http://wannier.org/code/${P}.tar.gz"
-SRC_URI="https://launchpad.net/${PN}/2.0/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-
-IUSE="mpi perl test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- virtual/blas
- virtual/lapack
- perl? ( dev-lang/perl )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-pkg_setup() {
- # fortran-2.eclass does not handle mpi wrappers
- if use mpi; then
- export FC="mpif90"
- export F77="mpif77"
- export CC="mpicc"
- export CXX="mpic++"
- export MPIFC="mpif90"
- export MPICC="mpicc"
- else
- tc-export FC F77 CC CXX
- fi
-
- # Preprocesor macross can make some lines really long
- append-fflags -ffree-line-length-none
-
- fortran-2_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/"$P"-runtest.patch
-}
-
-src_configure() {
- export LINALG_INCLUDES="$($(tc-getPKG_CONFIG) --cflags blas lapack)"
- export LINALG_LIBS="$($(tc-getPKG_CONFIG) --libs blas lapack)"
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- pushd "${BUILD_DIR}"/utility > /dev/null || die
- emake || die "emake in utility failed"
- popd > /dev/null || die
-}
-
-src_test() {
- einfo "Compare the 'Standard' and 'Current' outputs of this test."
-# cd tests
-# emake test
- autotools-utils_src_compile check
- cat "${BUILD_DIR}"/tests/wantest.log
-}
-
-src_install() {
- autotools-utils_src_install
- dobin "${BUILD_DIR}"/utility/w90pov/src/w90pov.x
- dobin "${BUILD_DIR}"/utility/PL_assessment/w90_pl_assess.x
- use perl && dobin "$S"/utility/w90_kmesh.pl
-}
diff --git a/sci-libs/wannier90/wannier90-2.0.1.ebuild b/sci-libs/wannier90/wannier90-3.1.0.ebuild
index 306e619b4..28bd897c4 100644
--- a/sci-libs/wannier90/wannier90-2.0.1.ebuild
+++ b/sci-libs/wannier90/wannier90-3.1.0.ebuild
@@ -1,28 +1,33 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils fortran-2 multilib toolchain-funcs
+inherit fortran-2 multilib toolchain-funcs
DESCRIPTION="Calculates maximally localized Wannier functions (MLWFs)"
HOMEPAGE="http://www.wannier.org/"
-SRC_URI="http://wannier.org/code/${P}.tar.gz"
+SRC_URI="https://github.com/wannier-developers/wannier90/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="examples perl static-libs test"
-RESTRICT="!test? ( test )"
+IUSE="examples perl static-libs"
RDEPEND="
virtual/blas
virtual/lapack
- perl? ( dev-lang/perl )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
+ virtual/mpi
+ perl? ( dev-lang/perl )
"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ cp config/make.inc.gfort make.inc || die
+}
src_configure() {
cat <<- EOF >> "${S}"/make.sys
@@ -33,16 +38,10 @@ src_configure() {
EOF
}
-src_compile() {
- emake -j1 wannier
- emake -j1 lib
-}
-
src_test() {
einfo "Compare the 'Standard' and 'Current' outputs of this test."
- cd tests
- emake test
- cat wantest.log
+ cd test-suite || die
+ ./run_tests --default || die
}
src_install() {