aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-30 12:38:29 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-30 12:38:29 +0100
commit70cdff75c8946fbae837f3f7dd50c51c75cd7302 (patch)
treeb35565e92807814aef6c6cc779fc81afce80c892 /sci-libs/vxl/vxl-2.0.2.ebuild
parentsci-libs/wannier90: version bump, EAPI bump (diff)
downloadsci-70cdff75c8946fbae837f3f7dd50c51c75cd7302.tar.gz
sci-70cdff75c8946fbae837f3f7dd50c51c75cd7302.tar.bz2
sci-70cdff75c8946fbae837f3f7dd50c51c75cd7302.zip
sci-libs/vxl: version bump, EAPI bump, add keywords
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-libs/vxl/vxl-2.0.2.ebuild')
-rw-r--r--sci-libs/vxl/vxl-2.0.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-libs/vxl/vxl-2.0.2.ebuild b/sci-libs/vxl/vxl-2.0.2.ebuild
new file mode 100644
index 000000000..0680cceb3
--- /dev/null
+++ b/sci-libs/vxl/vxl-2.0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake multilib
+
+DESCRIPTION="C++ computer vision research libraries"
+HOMEPAGE="https://vxl.github.io/"
+SRC_URI="https://github.com/vxl/vxl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sci-libs/libgeotiff"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ # install lib files to correct dir
+ mv "${ED}/usr/lib" "${ED}/usr/$(get_libdir)"
+}