aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-03-22 22:30:58 -0400
committerHorea Christian <chr@chymera.eu>2020-03-22 22:33:02 -0400
commite8025d93b0c85cbfba9b4a6467e2b86f900cb499 (patch)
tree3de1d28d4d3223082a0ca769b5728b7589d4113d /sci-biology
parentsci-biology/dipy: version bump 1.1.1 (diff)
downloadsci-e8025d93b0c85cbfba9b4a6467e2b86f900cb499.tar.gz
sci-e8025d93b0c85cbfba9b4a6467e2b86f900cb499.tar.bz2
sci-e8025d93b0c85cbfba9b4a6467e2b86f900cb499.zip
sci-biology/nireg: remove from tree.
Unmaintained as of 2016, not used by any packages Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/nilearn/Manifest1
-rw-r--r--sci-biology/nilearn/nilearn-0.6.2.ebuild61
-rw-r--r--sci-biology/nireg/metadata.xml15
-rw-r--r--sci-biology/nireg/nireg-9999.ebuild32
4 files changed, 62 insertions, 47 deletions
diff --git a/sci-biology/nilearn/Manifest b/sci-biology/nilearn/Manifest
index 6152553db..ead238d61 100644
--- a/sci-biology/nilearn/Manifest
+++ b/sci-biology/nilearn/Manifest
@@ -1,3 +1,4 @@
DIST nilearn-0.4.2.tar.gz 2837042 BLAKE2B 8cf9e37e6b51b423b13b796a0ff4150a1c5d36b4b09150298f82e55e1690cd0e21e2e9393467470e804c66a9c437c7650a665c2a34d74d40bfea31341c990ebd SHA512 13acce019c903885caaadd3c0ce103ef2450b475e3297e08008c66a35777d7615dae264bd78507cc4117f87a3dd0d417cc9e1653f2186ee5c959b54ad9b6e577
DIST nilearn-0.5.0.tar.gz 5654672 BLAKE2B f109c768aace07b2d22883dff7c1d6a855f5b951952be8d56cbe509fb582dddd6e6602d1a41612e361d7708bc19ee43fb7478a0a91c9337444942f28a79739f8 SHA512 de1b9a3aa0d3cb546ccaa5969e362f7a1720dfddf7625cb3e572eb3da676667e2f8a2a4307f3c911e444531b996d6ad213f2ef13b43b39dc658663f9b5e78a86
DIST nilearn-0.5.2.tar.gz 5586326 BLAKE2B 4b8e07be6a7a6171f83b233b54d6f4760548dda1d6a9de0f5571e38b613db9832d4eeb5fb387b783a6bec0cf2e70df91aee1459b408b78f7c92f16e961b88489 SHA512 482468a83f9d04b67ebf73b8b88706437c3c3b9547717102cd5688bae7e603fd5ad7d2d9cf694ea68c2bd764ec206e3f37a6284de11939c2611acb91016af356
+DIST nilearn-0.6.2.tar.gz 5890630 BLAKE2B 54bf4f52ea287a98ac29f2aaa9af90bed8f8a61e5d4cc3b9e9e5ca533d69537d0d1779d88faf823712bb3eee384e7d618b78cdae4cbd3c3bdfadeea24429f147 SHA512 98ff82f66aa29a4cadab00ac6cd6f3497822a63c2120f40458a491f4a93365b03e8e63dd9b42b53a45adf9287bd3466ade38cf18dec275aeb69b404ef7e64412
diff --git a/sci-biology/nilearn/nilearn-0.6.2.ebuild b/sci-biology/nilearn/nilearn-0.6.2.ebuild
new file mode 100644
index 000000000..c532ab0ad
--- /dev/null
+++ b/sci-biology/nilearn/nilearn-0.6.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast and easy statistical learning on NeuroImaging data"
+HOMEPAGE="http://nilearn.github.io/"
+SRC_URI="https://github.com/nilearn/nilearn/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plot test"
+
+# Tests attempt to download external data.
+RESTRICT="test"
+
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scikits_learn[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ plot? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+
+# (Temporarily) commented out, since Gentoo sci-libs/scikits_learn decided it
+# is a mess to maintain system joblib usage
+#PATCHES=( "${FILESDIR}/0.4.1-bundled_joblib_test.patch" )
+
+python_prepare_all() {
+ # upstream is reluctant to *not* depend on bundled scikits_learn:
+ # https://github.com/nilearn/nilearn/pull/1398
+ # (Temporarily) commented out, since Gentoo sci-libs/scikits_learn decided it
+ # is a mess to maintain system joblib usage
+ #local f
+ #for f in nilearn/{*/*/,*/,}*.py; do
+ # sed -r \
+ # -e '/^from/s/(sklearn|\.|)\.externals\.joblib/joblib/' \
+ # -e 's/from (sklearn|\.|)\.externals import/import/' \
+ # -i $f || die
+ #done
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ echo "backend: Agg" > matplotlibrc
+ #MPLCONFIGDIR=. nosetests -v || die
+ MPLCONFIGDIR=. pytest -vv || die
+}
diff --git a/sci-biology/nireg/metadata.xml b/sci-biology/nireg/metadata.xml
deleted file mode 100644
index d6592a893..000000000
--- a/sci-biology/nireg/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>horea.christ@gmail.com</email>
- <name>Horea Christian</name>
- </maintainer>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
-Nireg is a package for nytive-python image registration.
-</longdescription>
-</pkgmetadata>
diff --git a/sci-biology/nireg/nireg-9999.ebuild b/sci-biology/nireg/nireg-9999.ebuild
deleted file mode 100644
index 980307fff..000000000
--- a/sci-biology/nireg/nireg-9999.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Image registration package for Python"
-HOMEPAGE="http://nipy.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/nipy/${PN}"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-KEYWORDS=""
-
-COMMONDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${COMMONDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND="${COMMONDEPEND}
- sci-libs/scipy[${PYTHON_USEDEP}]
- sci-libs/nibabel[${PYTHON_USEDEP}]
- "
-
-python_test() {
- #nosetests -v || die
- python -c "import nireg; nireg.test()" || die
-}