aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-01-22 12:59:43 -0500
committerHorea Christian <chr@chymera.eu>2024-01-22 12:59:43 -0500
commitdd4ee9b222cf98145af87c7ca36dc3d0e40cd8c0 (patch)
tree2cfa52694200957b58c580a08d4ce237ad2f3b64 /sci-biology
parentprofiles: heudiconv package no longer affected by dropped dependency (diff)
downloadsci-dd4ee9b222cf98145af87c7ca36dc3d0e40cd8c0.tar.gz
sci-dd4ee9b222cf98145af87c7ca36dc3d0e40cd8c0.tar.bz2
sci-dd4ee9b222cf98145af87c7ca36dc3d0e40cd8c0.zip
sci-biology/SPAdes: keyword 3.15.5 for ~amd64
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/SPAdes/SPAdes-3.15.5.ebuild8
-rw-r--r--sci-biology/SPAdes/files/SPAdes-3.15.5-gcc13.patch49
2 files changed, 54 insertions, 3 deletions
diff --git a/sci-biology/SPAdes/SPAdes-3.15.5.ebuild b/sci-biology/SPAdes/SPAdes-3.15.5.ebuild
index b6d344c37..4485619e3 100644
--- a/sci-biology/SPAdes/SPAdes-3.15.5.ebuild
+++ b/sci-biology/SPAdes/SPAdes-3.15.5.ebuild
@@ -17,9 +17,7 @@ SRC_URI="
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-# Fails to build:
-# https://github.com/ablab/spades/issues/1238
+KEYWORDS="~amd64"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="
@@ -31,6 +29,10 @@ DEPEND="
RDEPEND="${DEPEND}"
BDEPEND="dev-build/cmake"
+PATCHES=(
+ "${FILESDIR}/${P}-gcc13.patch"
+)
+
src_install(){
einstalldocs
# WORKAROUND: This script does both compile and install in one go
diff --git a/sci-biology/SPAdes/files/SPAdes-3.15.5-gcc13.patch b/sci-biology/SPAdes/files/SPAdes-3.15.5-gcc13.patch
new file mode 100644
index 000000000..3dd3f8c02
--- /dev/null
+++ b/sci-biology/SPAdes/files/SPAdes-3.15.5-gcc13.patch
@@ -0,0 +1,49 @@
+From 3e802fa51d156fc958c36e25d607f20bf756f0bf Mon Sep 17 00:00:00 2001
+From: Bo YU <tsu.yubo@gmail.com>
+Date: Wed, 19 Jul 2023 18:42:04 +0800
+Subject: [PATCH] fix build issues due to gcc-13
+
+Signed-off-by: Bo YU <tsu.yubo@gmail.com>
+---
+ ext/include/llvm/Support/Signals.h | 1 +
+ src/common/pipeline/library_data.hpp | 1 +
+ src/common/sequence/nucl.hpp | 2 ++
+ 3 files changed, 4 insertions(+)
+
+diff --git a/assembler/ext/include/llvm/Support/Signals.h b/assembler/ext/include/llvm/Support/Signals.h
+index e0a18e72f..148216b8f 100644
+--- a/ext/include/llvm/Support/Signals.h
++++ b/ext/include/llvm/Support/Signals.h
+@@ -14,6 +14,7 @@
+ #ifndef LLVM_SUPPORT_SIGNALS_H
+ #define LLVM_SUPPORT_SIGNALS_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace llvm {
+diff --git a/assembler/src/common/pipeline/library_data.hpp b/assembler/src/common/pipeline/library_data.hpp
+index 3cbaf0adb..1ffaa7b37 100644
+--- a/src/common/pipeline/library_data.hpp
++++ b/src/common/pipeline/library_data.hpp
+@@ -8,6 +8,7 @@
+
+ #include <map>
+ #include <string>
++#include <cstdint>
+
+ // Forward decls for LLVM YAML API
+ namespace llvm { namespace yaml { class IO; template<typename T> struct MappingTraits; } }
+diff --git a/assembler/src/common/sequence/nucl.hpp b/assembler/src/common/sequence/nucl.hpp
+index 9c7d6de13..e10e7f583 100755
+--- a/src/common/sequence/nucl.hpp
++++ b/src/common/sequence/nucl.hpp
+@@ -8,6 +8,8 @@
+ #ifndef NUCL_HPP_
+ #define NUCL_HPP_
+
++#include <cstdint>
++
+ #include "utils/verify.hpp"
+
+ /**