aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-10-24 00:31:12 -0400
committerHorea Christian <chr@chymera.eu>2020-10-24 00:31:12 -0400
commit83fd8b496d322f3f6130ff251f0567486f35a14a (patch)
treeca6f2686c4c90b5a2702f9fd6417e736c2e36c2f /sci-biology/afni
parentsci-mathematics/gap: move gap-core to gap (diff)
downloadsci-83fd8b496d322f3f6130ff251f0567486f35a14a.tar.gz
sci-83fd8b496d322f3f6130ff251f0567486f35a14a.tar.bz2
sci-83fd8b496d322f3f6130ff251f0567486f35a14a.zip
sci-biology/afni: fixed build issues for systems missing python 2.7
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-biology/afni')
-rw-r--r--sci-biology/afni/afni-20.1.16.ebuild6
-rw-r--r--sci-biology/afni/files/afni-20.1.16-python.patch11
2 files changed, 16 insertions, 1 deletions
diff --git a/sci-biology/afni/afni-20.1.16.ebuild b/sci-biology/afni/afni-20.1.16.ebuild
index 4953408d6..09e2b7def 100644
--- a/sci-biology/afni/afni-20.1.16.ebuild
+++ b/sci-biology/afni/afni-20.1.16.ebuild
@@ -39,6 +39,10 @@ S="${WORKDIR}/${PN}-AFNI_${PV}/src"
BUILD="linux_fedora_19_64"
BIN_CONFLICTS=(qdelaunay whirlgif djpeg cjpeg qhull rbox count mpeg_encode)
+PATCHES=(
+ "${FILESDIR}/${P}-python.patch"
+)
+
src_prepare() {
find -type f -exec sed -i -e "s/-lXp //g" {} +
cp other_builds/Makefile.${BUILD} Makefile || die "Could not copy Makefile"
@@ -56,7 +60,7 @@ src_prepare() {
-i SUMA/SUMA_Makefile || die "Could not edit SUMA/SUMA_Makefile"
# upstream checks if $CC is EXACTLY gcc, else sets variables for Mac
find "${S}" -iname "*Makefile*" | xargs sed -e "s~/usr/~${EROOT}/usr/~g;" -i
- eapply_user
+ default
}
src_compile() {
diff --git a/sci-biology/afni/files/afni-20.1.16-python.patch b/sci-biology/afni/files/afni-20.1.16-python.patch
new file mode 100644
index 000000000..24ed98405
--- /dev/null
+++ b/sci-biology/afni/files/afni-20.1.16-python.patch
@@ -0,0 +1,11 @@
+--- a/other_builds/Makefile.linux_fedora_19_64 2020-10-09 07:07:58.348874414 -0400
++++ b/other_builds/Makefile.linux_fedora_19_64 2020-10-10 01:15:22.337755934 -0400
+@@ -11,8 +11,6 @@
+
+ # ------------------------------
+ # python from C
+-IPYTHON = -DSELENIUM_READY -I/usr/include/python2.7
+-LDPYTHON = -lpython2.7
+
+ # ----------------------------------------------------------------------
+ # X configuration