aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-10-23 20:54:16 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-26 12:30:32 +0200
commit2d0d3f4ff85978975d360f96969e323f129c5d53 (patch)
treede6852fe546bee2fa92c784b4bb6d66e52f259b2 /net-misc
parentnet-misc/cernbox-client: Drop old. (diff)
downloadsci-2d0d3f4ff85978975d360f96969e323f129c5d53.tar.gz
sci-2d0d3f4ff85978975d360f96969e323f129c5d53.tar.bz2
sci-2d0d3f4ff85978975d360f96969e323f129c5d53.zip
net-misc/cernbox-client: Bump to 2.9.1.5500.
Requires a small patch to the CERNBox theme due to ownCloud upstream changes to themeing. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/sci/pull/1116 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cernbox-client/Manifest1
-rw-r--r--net-misc/cernbox-client/cernbox-client-2.9.1.5500.ebuild83
-rw-r--r--net-misc/cernbox-client/files/cernbox-theme-2.9.1.patch11
3 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/cernbox-client/Manifest b/net-misc/cernbox-client/Manifest
index 42c7ca3a3..e83150294 100644
--- a/net-misc/cernbox-client/Manifest
+++ b/net-misc/cernbox-client/Manifest
@@ -1,2 +1,3 @@
DIST cernbox-client-2.7.1-2596.src.rpm 15434250 BLAKE2B 3ef3fcc4010b3f292aee9b6bba7b5f9a72e4fbca1236e1e85e6523cd4e38d980fe4542c5f019647a19040be64628159651630a61ee8894cb7bcf4b69d342ccd0 SHA512 e329b84fc7aa62068f934bf8a9f47432709094adc618274c1b8ddbf7331094cb71b6208d3a777150ee426141301e0279cb219d65b123335f2e198a9b87980e5d
DIST ownCloud-2.8.2.4246.tar.xz 15044652 BLAKE2B ee1ee412667266273a9a9722940559562c6c43213b013fe7c21328e04ac967afb16f460e6fa711f37d1d4ea7d0fc15fc398d835cf6a939f4c8dfd54cd4846fed SHA512 0ab2ef72191cc2d5c2621c97c09cb1d25472a30f511235a190465e246a8312f13a255011abb9690c481887f2f15094414c87ce594252eb8debcb39b9cbc8a178
+DIST ownCloud-2.9.1.5500.tar.xz 5787048 BLAKE2B 6f7df0c1ca13e6074bbd75caaee838ddb822f9284a4f5cc95e1b2c1432adf2969e2413607bebc1542d4bc7790bd6e61edfba758d2205a23fbede6873b7e22316 SHA512 5c78cd0318b7cd35f32721cf364d6e807d32eb1f3651e7f22ff3f3c7737967193ad089062965b3dcee24c23c14cc0d7acdfc95094f4f90f8aaf718f45f22e18a
diff --git a/net-misc/cernbox-client/cernbox-client-2.9.1.5500.ebuild b/net-misc/cernbox-client/cernbox-client-2.9.1.5500.ebuild
new file mode 100644
index 000000000..482b29c54
--- /dev/null
+++ b/net-misc/cernbox-client/cernbox-client-2.9.1.5500.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake rpm xdg
+
+DESCRIPTION="Synchronize files from CERNBox EOS with your computer"
+
+# Origin is classic owncloud-client, branded for CERN during compilation.
+ORIGIN_PN="ownCloud"
+BRANDED_P="cernbox"
+BRANDED_PV="2.7.1"
+BRANDED_REL="2596"
+HOMEPAGE="https://cernbox.cern.ch/"
+SRC_URI="http://download.owncloud.com/desktop/${ORIGIN_PN}/stable/${PV}/source/${ORIGIN_PN}-${PV}.tar.xz
+ https://cernbox.cern.ch/cernbox/doc/Linux/repo/CentOS_7/src/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm
+ https://cern.ch/ofreyerm/gentoo/cernbox/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dolphin gnome-keyring nautilus test"
+
+COMMON_DEPEND=">=dev-db/sqlite-3.4:3
+ dev-libs/qtkeychain[gnome-keyring?,qt5(+)]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-fs/inotify-tools
+ dolphin? (
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/kio:5
+ )
+ nautilus? ( dev-python/nautilus-python )"
+
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/linguist-tools:5
+ kde-frameworks/extra-cmake-modules
+ test? (
+ dev-util/cmocka
+ dev-qt/qttest:5
+ )"
+
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${ORIGIN_PN}-${PV}
+
+PATCHES=( "${FILESDIR}"/cernbox-theme-2.9.1.patch )
+
+src_unpack() {
+ rpm_src_unpack ${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm || die "failed to extract branding RPM"
+ mv ${PN%-*}-${BRANDED_PV}.${BRANDED_REL}/branding "${S}" || die "failed to extract branding"
+}
+
+src_prepare() {
+ # Keep tests in ${T}
+ sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die
+
+ if ! use nautilus; then
+ pushd shell_integration > /dev/null || die
+ cmake_comment_add_subdirectory nautilus
+ popd > /dev/null || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DBUILD_SHELL_INTEGRATION_DOLPHIN=$(usex dolphin)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
diff --git a/net-misc/cernbox-client/files/cernbox-theme-2.9.1.patch b/net-misc/cernbox-client/files/cernbox-theme-2.9.1.patch
new file mode 100644
index 000000000..c2ccbcc5e
--- /dev/null
+++ b/net-misc/cernbox-client/files/cernbox-theme-2.9.1.patch
@@ -0,0 +1,11 @@
+--- a/branding/cernbox-theme.h 2021-10-21 13:10:22.832842670 +0200
++++ b/branding/cernbox-theme.h 2021-10-21 13:14:57.394479817 +0200
+@@ -62,7 +62,7 @@
+
+
+ QString about() const {
+- QString devString = tr("<p>Version %1. For more information visit <a href=\"%2\">https://%3</a></p>").arg(Utility::escape(QStringLiteral(MIRALL_VERSION_STRING)), Utility::escape(QStringLiteral("https://" MIRALL_STRINGIFY(APPLICATION_DOMAIN))), Utility::escape(QStringLiteral(MIRALL_STRINGIFY(APPLICATION_DOMAIN))));
++ QString devString = tr("<p>Version %1. For more information visit <a href=\"%2\">https://%3</a></p>").arg(Utility::escape(QStringLiteral(MIRALL_VERSION_STRING)), Utility::escape(QStringLiteral("https://" APPLICATION_DOMAIN)), Utility::escape(QStringLiteral(APPLICATION_DOMAIN)));
+
+
+ return devString;