aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-27 13:43:40 -0500
committerHorea Christian <chr@chymera.eu>2023-01-27 13:43:40 -0500
commite9151ecdb32f15ba7a8f87e6fdfe28942ee40856 (patch)
tree870e021f928e0a3b76f2a4537418e954e6397268 /dev-python
parentsci-libs/nipy: revbump for numpy compatibility (diff)
downloadsci-e9151ecdb32f15ba7a8f87e6fdfe28942ee40856.tar.gz
sci-e9151ecdb32f15ba7a8f87e6fdfe28942ee40856.tar.bz2
sci-e9151ecdb32f15ba7a8f87e6fdfe28942ee40856.zip
dev-python/traits: added highest version before compat-breaking 6.4.*
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/traits/Manifest1
-rw-r--r--dev-python/traits/traits-6.3.2.ebuild36
-rw-r--r--dev-python/traits/traits-6.4.1.ebuild5
3 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/traits/Manifest b/dev-python/traits/Manifest
index ea39d56ff..8e8de91b3 100644
--- a/dev-python/traits/Manifest
+++ b/dev-python/traits/Manifest
@@ -1,2 +1,3 @@
DIST traits-6.1.1.tar.gz 567019 BLAKE2B 4b6ed46c87b1fda2a2001299106b5aacafbe8b148ba0564c4f39b67a8de76f6713366c8b00841db254a26c87a7b2b73b6935ecade770d92ad972aa8a0425cecf SHA512 7f7e9f11d4861c02164ae1ce595888859c8ce23213290cfc3ac11df100d33beeeea4c7def6799b70ef2d090b3f7bd98407f3605affff0867914d0fe0164dd50f
+DIST traits-6.3.2.tar.gz 9517139 BLAKE2B 9c6209a24fd07def86699174a66e2e0b3332670d974a75ead9486187c37e1c2c25b2a0c47e5444a03577931411ce6938b3b9ba195261a46c86d660c5abe9b502 SHA512 792004d88d2a00a1e9ba03974d58ec692b620f3c45aaf3bd82f93396818df8663a86903d43806c877230a66c5c8fee4d68268ed9355c166af00b5d060ba14c7d
DIST traits-6.4.1.tar.gz 9527016 BLAKE2B 12036eeb845cc3014b0cba9984e1c1686a6720630678d440a2059c47916c08284b1f823ca566dcb6c1c86594ebec5400bb2a8c44d43d765a25d00e157fbbda74 SHA512 04b936195d57320c02fee9f0d5e7dbcfee28add422c151bd4aaa6d1c58c59f8de7fe54b4df039bb2023ffc9dae9570bba52210cd015ce462e0f736e9439327e5
diff --git a/dev-python/traits/traits-6.3.2.ebuild b/dev-python/traits/traits-6.3.2.ebuild
new file mode 100644
index 000000000..57d555447
--- /dev/null
+++ b/dev-python/traits/traits-6.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="
+ https://docs.enthought.com/traits/
+ https://github.com/enthought/traits
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+# ToDo: Fix doc building:
+# AttributeError: 'NoDefaultSpecified' object has no attribute '__name__'
+#distutils_enable_sphinx docs/source --no-autodoc
+
+python_prepare_all() {
+ sed -i -e "s/'-O3'//g" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ ${EPYTHON} -m unittest discover || die
+}
diff --git a/dev-python/traits/traits-6.4.1.ebuild b/dev-python/traits/traits-6.4.1.ebuild
index 12afbe075..57d555447 100644
--- a/dev-python/traits/traits-6.4.1.ebuild
+++ b/dev-python/traits/traits-6.4.1.ebuild
@@ -8,9 +8,10 @@ PYTHON_COMPAT=( python3_10 )
inherit distutils-r1
DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="https://docs.enthought.com/traits/
+HOMEPAGE="
+ https://docs.enthought.com/traits/
https://github.com/enthought/traits
- https://pypi.org/project/traits/"
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"