aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-12 18:53:57 -0500
committerHorea Christian <chr@chymera.eu>2023-01-12 18:53:57 -0500
commitf51f644df30b8e93a607f84f5b30c64105021659 (patch)
tree7606097dd30f80339673320726c83fffeca04551 /dev-python/traits/traits-6.4.1.ebuild
parentdev-python/traits: Package uses unittests instead of nose (diff)
downloadsci-f51f644df30b8e93a607f84f5b30c64105021659.tar.gz
sci-f51f644df30b8e93a607f84f5b30c64105021659.tar.bz2
sci-f51f644df30b8e93a607f84f5b30c64105021659.zip
dev-python/traits: add 6.4.1
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/traits/traits-6.4.1.ebuild')
-rw-r--r--dev-python/traits/traits-6.4.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/traits/traits-6.4.1.ebuild b/dev-python/traits/traits-6.4.1.ebuild
new file mode 100644
index 000000000..12afbe075
--- /dev/null
+++ b/dev-python/traits/traits-6.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="https://docs.enthought.com/traits/
+ https://github.com/enthought/traits
+ https://pypi.org/project/traits/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+# ToDo: Fix doc building:
+# AttributeError: 'NoDefaultSpecified' object has no attribute '__name__'
+#distutils_enable_sphinx docs/source --no-autodoc
+
+python_prepare_all() {
+ sed -i -e "s/'-O3'//g" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ ${EPYTHON} -m unittest discover || die
+}