aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-12 05:14:56 -0500
committerHorea Christian <chr@chymera.eu>2023-01-12 05:16:03 -0500
commit9c0a8ea14cbfe5981e25b74011a3682d7cab2f91 (patch)
tree94bcf300f6bb330fa10ee010a45d8ff51fae4153 /dev-python/nwbinspector
parentdev-python/pynwb: fully deprecated ros3 flag of hdf5 dep (diff)
downloadsci-9c0a8ea14cbfe5981e25b74011a3682d7cab2f91.tar.gz
sci-9c0a8ea14cbfe5981e25b74011a3682d7cab2f91.tar.bz2
sci-9c0a8ea14cbfe5981e25b74011a3682d7cab2f91.zip
dev-python/nwbinspector: reinstating package
This reverts commit 84981dc9b0b8854985e33d2ff8dd8e22ea39e79d. Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/nwbinspector')
-rw-r--r--dev-python/nwbinspector/Manifest4
-rw-r--r--dev-python/nwbinspector/metadata.xml16
-rw-r--r--dev-python/nwbinspector/nwbinspector-0.3.9.ebuild29
-rw-r--r--dev-python/nwbinspector/nwbinspector-0.4.12.ebuild39
-rw-r--r--dev-python/nwbinspector/nwbinspector-0.4.14.ebuild39
-rw-r--r--dev-python/nwbinspector/nwbinspector-0.4.19.ebuild31
6 files changed, 158 insertions, 0 deletions
diff --git a/dev-python/nwbinspector/Manifest b/dev-python/nwbinspector/Manifest
new file mode 100644
index 000000000..9c121302b
--- /dev/null
+++ b/dev-python/nwbinspector/Manifest
@@ -0,0 +1,4 @@
+DIST nwbinspector-0.3.9.gh.tar.gz 443247 BLAKE2B 4d1adbca50ff0f5d8278d71063d1248a4b22da952de6dc3e4984d58285d1acecf5adfe85b2a624df20e8064a69fa2ffe2c4a23ec1d2a579446fc451e7cd04bd5 SHA512 e8752fadbfcdb9a46f5c16771d789995fdab378720861dbe15b100f8e07cfad58f99a75fbda8e7631f06ec5671e16b3ac48a002606b658b018d50dd62151cc5e
+DIST nwbinspector-0.4.12.gh.tar.gz 455926 BLAKE2B 4bb8b493367593fdd575535e574b8494980a60a6ed1983a08f895c106e03e25ad6cd76b6c72cfcc42a34778d5059c90940bc9907dc9d87569df79aeae1698135 SHA512 60bb799beaff61612e7993069a34f62e0b6053dc3e820474f33c020c02f8c7b11bed0bca7e2bb335edfd60b06159be90b1a50dfcd497f6a3fb0916dc49cf17b7
+DIST nwbinspector-0.4.14.gh.tar.gz 469679 BLAKE2B 96fc92be4b52626b6533ca3d6f9584991543b2de392733af70d7d71d2a98bc8c1455a78ea0a8a6682cd4c52d0e8ed7ebcb0ac439aea9e4a5503f1dbd8b8ef148 SHA512 a1199460420b092a1e9a8803d0f881c7998e4a75e3878cb80b1b44624b1984a63aca39d4b2631339f25a00fb46982289463a062324388edfdebff27e0b8c9faa
+DIST nwbinspector-0.4.19.gh.tar.gz 570101 BLAKE2B f3950a8e24225fe490a6454ab5cd429bcb741eeee9cf12591089508600d283b4242ef70427e116960d16367e16c6d5a5869cfcedd829500ce920387d8ebca916 SHA512 3ecd7d1db1d53c0ec5db986a211e56b4818c165a376d15e7a79ede9c8ca45560b6f302e3c9b1e960153d632bfa759660be4e44540399e272be3728d76fd52a7c
diff --git a/dev-python/nwbinspector/metadata.xml b/dev-python/nwbinspector/metadata.xml
new file mode 100644
index 000000000..ccdbc7f6d
--- /dev/null
+++ b/dev-python/nwbinspector/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">NeurodataWithoutBorders/nwbinspector</remote-id>
+ <remote-id type="pypi">nwbinspector</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nwbinspector/nwbinspector-0.3.9.ebuild b/dev-python/nwbinspector/nwbinspector-0.3.9.ebuild
new file mode 100644
index 000000000..b25a071ff
--- /dev/null
+++ b/dev-python/nwbinspector/nwbinspector-0.3.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Inspect NWB files for compliance with NWB Best Practices"
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/nwbinspector"
+SRC_URI="https://github.com/NeurodataWithoutBorders/nwbinspector/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
diff --git a/dev-python/nwbinspector/nwbinspector-0.4.12.ebuild b/dev-python/nwbinspector/nwbinspector-0.4.12.ebuild
new file mode 100644
index 000000000..2fd918bd9
--- /dev/null
+++ b/dev-python/nwbinspector/nwbinspector-0.4.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Inspect NWB files for compliance with NWB Best Practices"
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/nwbinspector"
+SRC_URI="https://github.com/NeurodataWithoutBorders/nwbinspector/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_inspector.py
+ tests/unit_tests/test_time_series.py
+ )
+ epytest
+}
diff --git a/dev-python/nwbinspector/nwbinspector-0.4.14.ebuild b/dev-python/nwbinspector/nwbinspector-0.4.14.ebuild
new file mode 100644
index 000000000..2fd918bd9
--- /dev/null
+++ b/dev-python/nwbinspector/nwbinspector-0.4.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Inspect NWB files for compliance with NWB Best Practices"
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/nwbinspector"
+SRC_URI="https://github.com/NeurodataWithoutBorders/nwbinspector/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_inspector.py
+ tests/unit_tests/test_time_series.py
+ )
+ epytest
+}
diff --git a/dev-python/nwbinspector/nwbinspector-0.4.19.ebuild b/dev-python/nwbinspector/nwbinspector-0.4.19.ebuild
new file mode 100644
index 000000000..f18fc135f
--- /dev/null
+++ b/dev-python/nwbinspector/nwbinspector-0.4.19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Inspect NWB files for compliance with NWB Best Practices"
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/nwbinspector"
+SRC_URI="https://github.com/NeurodataWithoutBorders/nwbinspector/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+distutils_enable_tests pytest