aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-18 19:53:33 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-18 19:53:33 +0100
commit70d12c8b741e74bfdc4b5125c3b178703e3ed6f2 (patch)
treea31132190c379a2ec61bb9a80cd2f31639bb1bc5 /dev-perl
parentsci-biology/canu: use perl_domodule (diff)
downloadsci-70d12c8b741e74bfdc4b5125c3b178703e3ed6f2.tar.gz
sci-70d12c8b741e74bfdc4b5125c3b178703e3ed6f2.tar.bz2
sci-70d12c8b741e74bfdc4b5125c3b178703e3ed6f2.zip
dev-perl/Bio-EnsEMBL: use perl_domodule
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Bio-EnsEMBL/Bio-EnsEMBL-9999.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/dev-perl/Bio-EnsEMBL/Bio-EnsEMBL-9999.ebuild b/dev-perl/Bio-EnsEMBL/Bio-EnsEMBL-9999.ebuild
index 80014f94f..f2d7c6a54 100644
--- a/dev-perl/Bio-EnsEMBL/Bio-EnsEMBL-9999.ebuild
+++ b/dev-perl/Bio-EnsEMBL/Bio-EnsEMBL-9999.ebuild
@@ -18,7 +18,6 @@ S="${WORKDIR}"
src_install(){
perl_set_version
- insinto "${VENDOR_LIB}" # do not add "${PN}" so the the PERL path starts with Bio/
find . -name t | xargs rm -rf || die
find . -name test.pl | xargs rm -f || die
find . -name \*.example | xargs rm -f || die
@@ -27,5 +26,5 @@ src_install(){
find . -name \*.conf | xargs rm -f || die
find . -name travisci | xargs rm -rf || die
find . -name sql | xargs rm -rf || die
- find . -name modules | while read d; do pushd "$d"; doins -r *; popd; done || die
+ find . -name modules | while read d; do pushd "$d"; perl_domodule -r *; popd; done || die
}