aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-02-01 11:56:39 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-02-01 11:56:39 +0100
commitd31c4c6fff1670477cf208d00b87997b5c6bbe4e (patch)
tree6f6fa324c7fbb7c1e465cdc74e2cbd473b33355e /dev-libs
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-d31c4c6fff1670477cf208d00b87997b5c6bbe4e.tar.gz
sci-d31c4c6fff1670477cf208d00b87997b5c6bbe4e.tar.bz2
sci-d31c4c6fff1670477cf208d00b87997b5c6bbe4e.zip
New package dev-libs/boost-compute
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost-compute/ChangeLog10
-rw-r--r--dev-libs/boost-compute/Manifest1
l---------dev-libs/boost-compute/boost-compute-0.4.ebuild1
-rw-r--r--dev-libs/boost-compute/boost-compute-9999.ebuild28
-rw-r--r--dev-libs/boost-compute/metadata.xml15
5 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/boost-compute/ChangeLog b/dev-libs/boost-compute/ChangeLog
new file mode 100644
index 000000000..eefb055eb
--- /dev/null
+++ b/dev-libs/boost-compute/ChangeLog
@@ -0,0 +1,10 @@
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*boost-compute-9999 (01 Feb 2015)
+*boost-compute-0.4 (01 Feb 2015)
+
+ 01 Feb 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +metadata.xml, +boost-compute-9999.ebuild, +boost-compute-0.4.ebuild:
+ Add Boost.Compute to overlay
+ \ No newline at end of file
diff --git a/dev-libs/boost-compute/Manifest b/dev-libs/boost-compute/Manifest
new file mode 100644
index 000000000..d068af6c5
--- /dev/null
+++ b/dev-libs/boost-compute/Manifest
@@ -0,0 +1 @@
+DIST boost-compute-0.4.tar.gz 282477 SHA256 d6986155d01a02b12351d6c9cc6c85498292209c3949b3a4628c0712ec7cf01b SHA512 7a2b4f227b2f0a46ba44aeddc4b562e125949f262ef057c92b9261c9e0fa7a824323b3dbb0bb5129b76fce4be93bbb1fccf5d681d63663731c83c3ab80e5ceed WHIRLPOOL 9a2831030ae644e42b6b25be00647fde7e09d018035706c8142c6b80fcda6c2c9687a98cb4f7f5fd43e1ca5026d596351be6a62fb3f2ccc149fe9c025e63ca16
diff --git a/dev-libs/boost-compute/boost-compute-0.4.ebuild b/dev-libs/boost-compute/boost-compute-0.4.ebuild
new file mode 120000
index 000000000..9782d2a2f
--- /dev/null
+++ b/dev-libs/boost-compute/boost-compute-0.4.ebuild
@@ -0,0 +1 @@
+boost-compute-9999.ebuild \ No newline at end of file
diff --git a/dev-libs/boost-compute/boost-compute-9999.ebuild b/dev-libs/boost-compute/boost-compute-9999.ebuild
new file mode 100644
index 000000000..320fa9d85
--- /dev/null
+++ b/dev-libs/boost-compute/boost-compute-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A header-only C++ Computing Library for OpenCL"
+HOMEPAGE="https://github.com/kylelutz/compute"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kylelutz/compute.git git://github.com/kylelutz/compute.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/kylelutz/compute/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/compute-${PV}"
+fi
+
+RDEPEND="
+ dev-libs/boost
+ virtual/opencl
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-libs/boost-compute/metadata.xml b/dev-libs/boost-compute/metadata.xml
new file mode 100644
index 000000000..ae0b30066
--- /dev/null
+++ b/dev-libs/boost-compute/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <longdescription>
+ Boost.Compute is a GPU/parallel-computing library for C++ based on
+ OpenCL. The core library is a thin C++ wrapper over the OpenCL API
+ and provides access to compute devices, contexts, command queues
+ and memory buffers.
+ </longdescription>
+</pkgmetadata>