aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-06-27 17:16:14 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-06-27 17:18:54 +0200
commitc52bb278a1b5831f0af48dfff1f6629015b7a213 (patch)
treeea8ad8cd8541599fe123cf16d5faafd83def7e72
parentdev-python/boost-histogram: add 1.4.1, drop 1.4.0 (diff)
downloadsci-c52bb278a1b5831f0af48dfff1f6629015b7a213.tar.gz
sci-c52bb278a1b5831f0af48dfff1f6629015b7a213.tar.bz2
sci-c52bb278a1b5831f0af48dfff1f6629015b7a213.zip
dev-python/archspec: add 0.2.4, drop 0.2.2, drop 0.1.4
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--dev-python/archspec/Manifest3
-rw-r--r--dev-python/archspec/archspec-0.1.4.ebuild19
-rw-r--r--dev-python/archspec/archspec-0.2.4.ebuild (renamed from dev-python/archspec/archspec-0.2.2.ebuild)10
3 files changed, 10 insertions, 22 deletions
diff --git a/dev-python/archspec/Manifest b/dev-python/archspec/Manifest
index 8ad1830fc..c3dd31924 100644
--- a/dev-python/archspec/Manifest
+++ b/dev-python/archspec/Manifest
@@ -1,2 +1 @@
-DIST archspec-0.1.4.tar.gz 35184 BLAKE2B fe05cab539163d986e639e7e9cf57db208f9cce7ee447d2d3207af0bad68f2d5410e720e5f73376f950b9672602885fe34942fb885d7acbb8ad7e31b7f139ee0 SHA512 28da79ba1469db38ab1424be49feba87378c252ead5ad07fca8ae752dc3503d281f2f3f30391fe6209b118800f357b5219593c2d0d11608d683e56c95ca8f286
-DIST archspec-0.2.2.tar.gz 38306 BLAKE2B c8f8011e122d31a603120231b5f4f034316e06412d64e0bb0fe38886508470d264f7a20da5ef79634fa5ba2f3d3b176b08151f9b5d72d64dbc5c90ce9bd6ff42 SHA512 e2310ca041064109358c918abbdfb581a1494d51d4c0f41e6172fdb9defcefd60f1b80ae2187c8143e37569c815fdc29508d52c048fe88c8c198e85997cef34d
+DIST archspec-0.2.4.tar.gz 52834 BLAKE2B cb8b9fce38b44783a361568667d5690e5c5169149ebdd3d4bf0943c056a4c8c9e2cb3a13a0b9b39e07f9b907b8f5ec4d1552a925d2e9bee76acf858d1a3f3ed5 SHA512 40a83854982670cb5cf77aab496198b3c6723a5cc386f05b8a020d9e94834d4109436cade9b9c89abac909c17b912f00aab8df2d6b05251c0afba9cee1932a62
diff --git a/dev-python/archspec/archspec-0.1.4.ebuild b/dev-python/archspec/archspec-0.1.4.ebuild
deleted file mode 100644
index 35500e00d..000000000
--- a/dev-python/archspec/archspec-0.1.4.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517=poetry
-inherit distutils-r1 pypi
-
-DESCRIPTION="labels for various aspects of a system architecture like CPU, etc."
-HOMEPAGE="https://archspec.readthedocs.io/en/latest/index.html"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/six-1.16.0[${PYTHON_USEDEP}]
- <=dev-python/six-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
diff --git a/dev-python/archspec/archspec-0.2.2.ebuild b/dev-python/archspec/archspec-0.2.4.ebuild
index a7287fc72..002a57ba1 100644
--- a/dev-python/archspec/archspec-0.2.2.ebuild
+++ b/dev-python/archspec/archspec-0.2.4.ebuild
@@ -1,6 +1,6 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
DISTUTILS_USE_PEP517=poetry
inherit distutils-r1 pypi
@@ -11,3 +11,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
+BDEPEND="
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest