aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 13:39:22 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:23 +0200
commitc1cb19c3fccb993c4c82696cab7e31c17f390c54 (patch)
tree87b352930c8633a4cba8b6072c6ef8b6f712cc81
parentsci-physics/uproot: add 5.4.1 (diff)
downloadsci-c1cb19c3fccb993c4c82696cab7e31c17f390c54.tar.gz
sci-c1cb19c3fccb993c4c82696cab7e31c17f390c54.tar.bz2
sci-c1cb19c3fccb993c4c82696cab7e31c17f390c54.zip
sci-physics/scikit-hep-testdata: add 0.4.48
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--sci-physics/scikit-hep-testdata/Manifest1
-rw-r--r--sci-physics/scikit-hep-testdata/scikit-hep-testdata-0.4.48.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-physics/scikit-hep-testdata/Manifest b/sci-physics/scikit-hep-testdata/Manifest
index 1051bc85d..7a8a88f93 100644
--- a/sci-physics/scikit-hep-testdata/Manifest
+++ b/sci-physics/scikit-hep-testdata/Manifest
@@ -1 +1,2 @@
DIST scikit-hep-testdata-0.4.39.gh.tar.gz 340561478 BLAKE2B 9d0fc60c8bd9c11b5cd786389489b095a5498c7e08c744106d3bacd3f203f4b186f50a5e1ef6cbdcb23fc5d975807277cc25397ea8049e2acccbbc06c53f65d2 SHA512 fe31302178b8148b0486fe314a9d40c7a4318e53113878769484cc79dd55e5adb977357a175ffad887a205e1ea3e99a4f5be192581cca61554ba2187daad3bd2
+DIST scikit-hep-testdata-0.4.48.gh.tar.gz 340986304 BLAKE2B 84f4f5d0c3a883bc182f5c547b4a91e8efef478046d16c2199647e6a66b7e7888e06ee8dd8643eaeb05e6106849d0e5215ef450a28b1a4bb6840a7a07c3475f0 SHA512 328f78f501656a684a935ff196d9d184d6d8a9a215d77ac70afbeba33a4716834343569a3b4cea870a4c4ba300a7291a1a07322369b6f0f4f2a57acbd081a34e
diff --git a/sci-physics/scikit-hep-testdata/scikit-hep-testdata-0.4.48.ebuild b/sci-physics/scikit-hep-testdata/scikit-hep-testdata-0.4.48.ebuild
new file mode 100644
index 000000000..873bf6609
--- /dev/null
+++ b/sci-physics/scikit-hep-testdata/scikit-hep-testdata-0.4.48.ebuild
@@ -0,0 +1,37 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="A package to provide example files for testing and developing packages against."
+HOMEPAGE="https://github.com/scikit-hep/scikit-hep-testdata"
+# pypi does not include the data nor tests
+SRC_URI="https://github.com/scikit-hep/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+# Fails without this
+S="${WORKDIR}/${P}"
+# export is needed here!
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+# otherwise we don't install the data
+export SKHEP_DATA=1
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+EPYTEST_IGNORE=(
+ test_remote_files.py # we are net sandboxed
+)
+EPYTEST_DESELECT=(
+ tests/test_local_files.py::test_data_path_cached # https://github.com/scikit-hep/scikit-hep-testdata/issues/161
+)
+
+distutils_enable_tests pytest