aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-22 08:08:27 -0400
committerAisha Tammy <gentoo@aisha.cc>2020-09-22 08:09:09 -0400
commit882077ddaa6702ff9b2937f438ca77758176f454 (patch)
tree50639d9a06933c914114bf3d377c10d1a429ae42
parentsci-chemistry/wxmacmolplt: drop package (diff)
downloadsci-882077ddaa6702ff9b2937f438ca77758176f454.tar.gz
sci-882077ddaa6702ff9b2937f438ca77758176f454.tar.bz2
sci-882077ddaa6702ff9b2937f438ca77758176f454.zip
sci-libs/armadillo: drop package
present in ::gentoo Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--sci-libs/armadillo/Manifest1
-rw-r--r--sci-libs/armadillo/armadillo-6.700.5.ebuild121
-rw-r--r--sci-libs/armadillo/metadata.xml43
3 files changed, 0 insertions, 165 deletions
diff --git a/sci-libs/armadillo/Manifest b/sci-libs/armadillo/Manifest
deleted file mode 100644
index 874b79ad8..000000000
--- a/sci-libs/armadillo/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST armadillo-6.700.5.tar.gz 5470242 SHA256 d5817a8ff07da3bd8753b1e037ef39e7a6c81d88bb7119a2a8e6c3dc93b48db1 SHA512 1472056a809cc9f79c4e235c871253c689aa359c05efb158c98c8816b9ce7e4997e17bdaf6965711b3d1cc408d2ca74e1d438dcc5aa08cd322b352935f75887d WHIRLPOOL 803f7f02a726dc6ace0b980aac1503509d0d741e4794f1a8578e5c8d9665038007ae8841e1c59f8d63002ea91cd86139e22b6d64d3f2317929adf239bba8808b
diff --git a/sci-libs/armadillo/armadillo-6.700.5.ebuild b/sci-libs/armadillo/armadillo-6.700.5.ebuild
deleted file mode 100644
index eb62a2209..000000000
--- a/sci-libs/armadillo/armadillo-6.700.5.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-CMAKE_IN_SOURCE_BUILD=1
-
-inherit cmake-utils toolchain-funcs
-
-DESCRIPTION="Streamlined C++ linear algebra library"
-HOMEPAGE="http://arma.sourceforge.net/"
-SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0/6"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="arpack atlas blas debug doc examples hdf5 lapack mkl superlu tbb test"
-REQUIRED_USE="test? ( lapack )"
-
-RDEPEND="
- dev-libs/boost
- arpack? ( sci-libs/arpack )
- atlas? ( sci-libs/atlas[lapack] )
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
- superlu? ( sci-libs/superlu )
-"
-DEPEND="${RDEPEND}
- arpack? ( virtual/pkgconfig )
- atlas? ( virtual/pkgconfig )
- blas? ( virtual/pkgconfig )
- hdf5? ( sci-libs/hdf5 )
- lapack? ( virtual/pkgconfig )
- mkl? ( sci-libs/mkl )
- tbb? ( dev-cpp/tbb )"
-PDEPEND="${RDEPEND}
- hdf5? ( sci-libs/hdf5 )
- mkl? ( sci-libs/mkl )
- tbb? ( dev-cpp/tbb )"
-
-src_prepare() {
- # avoid the automagic cmake macros
- sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DINSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
- -DARMA_EXTRA_DEBUG="$(usex debug)"
- -DARMA_USE_MKL_ALLOC="$(usex mkl)"
- -DARMA_USE_TBB_ALLOC="$(usex tbb)"
- )
- if use arpack; then
- mycmakeargs+=(
- -DARPACK_FOUND=ON
- -DARPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs arpack)"
- )
- fi
- if use atlas; then
- local c=atlas-cblas l=atlas-clapack
- $(tc-getPKG_CONFIG) --exists ${c}-threads && c+=-threads
- $(tc-getPKG_CONFIG) --exists ${l}-threads && l+=-threads
- mycmakeargs+=(
- -DCBLAS_FOUND=ON
- -DCBLAS_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${c} | sed 's/-I//')"
- -DCBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${c})"
- -DCLAPACK_FOUND=ON
- -DCLAPACK_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${l} | sed 's/-I//')"
- -DCLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${l})"
- )
- fi
- if use blas; then
- mycmakeargs+=(
- -DBLAS_FOUND=ON
- -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
- )
- fi
- if use hdf5; then
- mycmakeargs+=(
- -DHDF5_FOUND=ON
- -DHDF5_LIBRARIES="-lhdf5"
- )
- fi
- if use lapack; then
- mycmakeargs+=(
- -DLAPACK_FOUND=ON
- -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
- )
- fi
- if use superlu; then
- mycmakeargs+=(
- -DSuperLU_FOUND=ON
- -DSuperLU_LIBRARIES="$($(tc-getPKG_CONFIG) --libs superlu)"
- -DSuperLU_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I superlu | awk '{print $1}' | sed 's/-I//')"
- )
- fi
-
- cmake-utils_src_configure
-}
-
-src_test() {
- pushd examples > /dev/null
- emake \
- CXX="$(tc-getCXX)" \
- CXXFLAGS="-I../include ${CXXFLAGS} -DARMA_USE_BLAS -DARMA_USE_LAPACK" \
- LIB_FLAGS="-L.. $($(tc-getPKG_CONFIG) --libs blas lapack)"
- LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example1 || die
- emake clean
- popd > /dev/null
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc README.txt
- use doc && dodoc *pdf *html
- if use examples; then
- insinto /usr/share/examples/${PF}
- doins -r examples/*
- fi
-}
diff --git a/sci-libs/armadillo/metadata.xml b/sci-libs/armadillo/metadata.xml
deleted file mode 100644
index af1c24703..000000000
--- a/sci-libs/armadillo/metadata.xml
+++ /dev/null
@@ -1,43 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
-Armadillo is a C++ linear algebra library (matrix maths) aiming
-towards a good balance between speed and ease of use. Integer,
-floating point and complex numbers are supported, as well as a
-subset of trigonometric and statistics functions. Various matrix
-decompositions are provided through optional integration with LAPACK
-and ATLAS libraries.
-A delayed evaluation approach is employed (during compile time) to
-combine several operations into one and reduce (or eliminate) the
-need for temporaries. This is accomplished through recursive
-templates and template meta-programming.
-</longdescription>
- <use>
- <flag name="atlas">
-Link with <pkg>sci-libs/atlas</pkg> libraries for cblas and
-clapack
-</flag>
- <flag name="arpack">
-Link with <pkg>sci-libs/arpack</pkg> libraries for eigen decomposition
-</flag>
- <flag name="mkl">
-Use matrix allocation from the Intel MKL <pkg>sci-libs/mkl</pkg>
-</flag>
- <flag name="tbb">
-Use matrix allocation from the Threads Building Blocks
-<pkg>dev-cpp/tbb</pkg>
-</flag>
- <flag name="superlu">
-Use SuperLU for sparse linear equation solving
-<pkg>sci-libs/superlu</pkg>
-</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">arma</remote-id>
- </upstream>
-</pkgmetadata>