aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElias Probst <mail@eliasprobst.eu>2014-08-20 23:51:31 +0200
committerElias Probst <mail@eliasprobst.eu>2014-08-20 23:51:31 +0200
commit50edfb7a66d7f27d07dab8fe770930aa979f612e (patch)
tree29a0f738488950159e8d31e372033c936d2be4a6 /app-crypt
parent[qt5-build.eclass] Stop defining/exporting pkg_setup. (diff)
downloadqt-50edfb7a66d7f27d07dab8fe770930aa979f612e.tar.gz
qt-50edfb7a66d7f27d07dab8fe770930aa979f612e.tar.bz2
qt-50edfb7a66d7f27d07dab8fe770930aa979f612e.zip
[app-crypt/qca] Install the QCA plugins into the Qt plugin directory.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca/qca-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/app-crypt/qca/qca-9999.ebuild b/app-crypt/qca/qca-9999.ebuild
index a2d91a18..f290f438 100644
--- a/app-crypt/qca/qca-9999.ebuild
+++ b/app-crypt/qca/qca-9999.ebuild
@@ -68,6 +68,11 @@ src_configure() {
$(with_plugin_use pkcs11)
$(with_plugin_use softstore)
)
+ if use qt4; then
+ mycmakeargs+=(-DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)/qt4/plugins/crypto")
+ else
+ mycmakeargs+=(-DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)/qt5/plugins/crypto")
+ fi
cmake-utils_src_configure
}