aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2020-11-18 21:55:23 -0700
committerTim Harder <radhermit@gmail.com>2020-11-18 21:56:37 -0700
commit9bf3baf67f9595b1b3c15506e0f44036a656cccc (patch)
treed5e8f24106e581ee35cef882cc79a3309549a477 /setup.py
parentpkgcheck scan: simplify bypassing repo determination when piping targets (diff)
downloadpkgcheck-9bf3baf67f9595b1b3c15506e0f44036a656cccc.tar.gz
pkgcheck-9bf3baf67f9595b1b3c15506e0f44036a656cccc.tar.bz2
pkgcheck-9bf3baf67f9595b1b3c15506e0f44036a656cccc.zip
remove old, unused plugins support
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 02100837..2a5bf27c 100755
--- a/setup.py
+++ b/setup.py
@@ -33,15 +33,6 @@ class install(pkgdist.install):
# rather than assuming it is running from a tarball/git repo.
write_obj_lists(self.install_purelib, target)
- # Install module plugincache
- # TODO: move this to pkgdist once plugin support is moved to snakeoil
- with pkgdist.syspath(pkgdist.PACKAGEDIR):
- from pkgcheck import plugins
- from pkgcore import plugin
- log.info('Generating plugin cache')
- path = os.path.join(self.install_purelib, 'pkgcheck', 'plugins')
- plugin.initialize_cache(plugins, force=True, cache_dir=path)
-
def write_obj_lists(python_base, install_prefix):
"""Generate config file of keyword, check, and other object lists."""