aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gmail.com>2010-09-03 15:53:04 +0200
committerDiego Elio Pettenò <flameeyes@gmail.com>2010-09-03 15:53:04 +0200
commitdad2c4127bdc027569db5581f54ef9c0bc85dd54 (patch)
tree2278c2910ba40da2f6552977b7be59e115673fc2 /Makefile
parentAlso protect account and password from pam_krb5 bad jumps. (diff)
downloadpambase-dad2c4127bdc027569db5581f54ef9c0bc85dd54.tar.gz
pambase-dad2c4127bdc027569db5581f54ef9c0bc85dd54.tar.bz2
pambase-dad2c4127bdc027569db5581f54ef9c0bc85dd54.zip
Add support for building minimal PAM chains.pambase-20100925pambase-20100903
When setting the MINIMAL flag on, the generated PAM chains will not use tally, motd, mail or lastlog modules, making th elogin quiet and skipping over the update of the login files.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 18a30d2..31482e8 100644
--- a/Makefile
+++ b/Makefile
@@ -56,6 +56,10 @@ ifeq "$(DEBUG)" "yes"
PAMFLAGS += -DDEBUG=debug
endif
+ifeq "$(MINIMAL)" "yes"
+PAMFLAGS += -DMINIMAL
+endif
+
all: $(PAMD)
install: $(PAMD)