aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2010-07-23 15:59:44 +0200
committerDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2010-07-23 15:59:44 +0200
commit736f9b9f43c2468dd0cb5c5343cb8969d5492a4d (patch)
tree74950657d26fb7e78b254ca64e1acbbd69cca32d /Makefile
parentImprove handling of services and the session chain. (diff)
downloadpambase-736f9b9f43c2468dd0cb5c5343cb8969d5492a4d.tar.gz
pambase-736f9b9f43c2468dd0cb5c5343cb8969d5492a4d.tar.bz2
pambase-736f9b9f43c2468dd0cb5c5343cb8969d5492a4d.zip
Add support for pam_krb5 module for Kerberos authentication.
This implements drop-in support for Kerberos (pam_krb5) in Gentoo systems; if the kerberos USE flag has been enabled, it'll use pam_krb5 for login, ignoring pam_unix, but no other module in the chain. It requires Linux-PAM.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 6a80ec5..18a30d2 100644
--- a/Makefile
+++ b/Makefile
@@ -44,6 +44,10 @@ ifeq "$(PAM_SSH)" "yes"
PAMFLAGS += -DHAVE_PAM_SSH=1
endif
+ifeq "$(KRB5)" "yes"
+PAMFLAGS += -DHAVE_KRB5=1
+endif
+
ifeq "$(SHA512)" "yes"
PAMFLAGS += -DWANT_SHA512=1
endif