aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am6
-rw-r--r--data/hostname1.xml (renamed from data/hostnamed.xml)1
2 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 58a1dea..6b6cb78 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
EXTRA_DIST = \
- data/hostnamed.xml \
+ data/hostname1.xml \
$(NULL)
AM_CPPFLAGS = \
@@ -33,12 +33,12 @@ openrc_settingsd_SOURCES = \
src/main.c \
$(NULL)
-$(hostnamed_built_sources) : data/hostnamed.xml
+$(hostnamed_built_sources) : data/hostname1.xml
( $(GDBUS_CODEGEN) \
--interface-prefix org.freedesktop. \
--c-namespace OpenrcSettingsdHostnamed \
--generate-c-code hostnamed-generated \
- $(srcdir)/data/hostnamed.xml; \
+ $(srcdir)/data/hostname1.xml; \
mv hostnamed-generated.{c,h} $(top_srcdir)/src/ )
BUILT_SOURCES = $(hostnamed_built_sources)
diff --git a/data/hostnamed.xml b/data/hostname1.xml
index 80c0216..7a731f6 100644
--- a/data/hostnamed.xml
+++ b/data/hostname1.xml
@@ -1,3 +1,4 @@
+<!DOCTYPE node PUBLIC "-//freedesktop//DTD D-BUS Object Introspection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd">
<node name="/org/freedesktop/hostname1">
<interface name="org.freedesktop.hostname1">
<method name="SetHostname">