summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-05-19 09:52:37 +0200
committerUlrich Müller <ulm@gentoo.org>2021-05-19 09:52:37 +0200
commitb1bab6a516c5512e84ed70b38f0750654ab4a5f5 (patch)
tree76c450c5848177955765711f444d60d8cb691f18
parentmetadata.rnc: Update from DTD (diff)
downloadnxml-gentoo-schemas-b1bab6a516c5512e84ed70b38f0750654ab4a5f5.tar.gz
nxml-gentoo-schemas-b1bab6a516c5512e84ed70b38f0750654ab4a5f5.tar.bz2
nxml-gentoo-schemas-b1bab6a516c5512e84ed70b38f0750654ab4a5f5.zip
userinfo.rnc: File restored
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--Makefile2
-rw-r--r--schemas.xml1
-rw-r--r--userinfo.rnc44
3 files changed, 46 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 304ae7e..e9c6372 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
DTDS = devbook.dtd glsa.dtd metadata.dtd mirrors.dtd \
- projects.dtd repositories.dtd
+ projects.dtd repositories.dtd userinfo.dtd
RNCS = $(patsubst %.dtd,%.rnc,$(DTDS))
diff --git a/schemas.xml b/schemas.xml
index 0a7f23c..f93bcbb 100644
--- a/schemas.xml
+++ b/schemas.xml
@@ -10,4 +10,5 @@
<documentElement localName="pkgmetadata" uri="metadata.rnc" />
<documentElement localName="projects" uri="projects.rnc" />
<documentElement localName="repositories" uri="repositories.rnc" />
+ <documentElement localName="userlist" uri="userinfo.rnc" />
</locatingRules>
diff --git a/userinfo.rnc b/userinfo.rnc
new file mode 100644
index 0000000..54a1305
--- /dev/null
+++ b/userinfo.rnc
@@ -0,0 +1,44 @@
+userlist = element userlist { attlist.userlist, user+ }
+attlist.userlist &= empty
+user =
+ element user {
+ attlist.user,
+ realname,
+ pgpkey+,
+ alias*,
+ email+,
+ joined*,
+ retired*,
+ status?,
+ roles?,
+ location?
+ }
+attlist.user &= attribute username { xsd:ID }
+realname = element realname { attlist.realname, firstname, familyname }
+attlist.realname &= attribute fullname { text }?
+firstname = element firstname { attlist.firstname, text }
+attlist.firstname &= empty
+familyname = element familyname { attlist.familyname, text }
+attlist.familyname &= attribute sort { text }?
+pgpkey = element pgpkey { attlist.pgpkey, text }
+attlist.pgpkey &= empty
+alias = element alias { attlist.alias, text }
+attlist.alias &= empty
+email = element email { attlist.email, text }
+attlist.email &= empty
+# all dates should be YYYY-MM-DD - eg '2006-11-22'
+joined = element joined { attlist.joined, text }
+attlist.joined &= empty
+retired = element retired { attlist.retired, text }
+attlist.retired &= empty
+status = element status { attlist.status, text }
+attlist.status &= empty
+roles = element roles { attlist.roles, text }
+attlist.roles &= empty
+# Location is the string displayed on the webpage
+location = element location { attlist.location, text }
+# signed decimal numbers. degrees north/east.
+attlist.location &=
+ attribute latitude { text }?,
+ attribute longitude { text }?
+start = userlist