aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>1999-01-13 14:01:25 +0000
committerPhil Blundell <philb@gnu.org>1999-01-13 14:01:25 +0000
commit2b17cc4fa2b31cd75021fa5c0222969643b0452a (patch)
treeefc36045eb2c3491b86df2b8a813c6a165514e67 /Makefile
parentFix IPv6 compilation problems. (diff)
downloadnet-tools-2b17cc4fa2b31cd75021fa5c0222969643b0452a.tar.gz
net-tools-2b17cc4fa2b31cd75021fa5c0222969643b0452a.tar.bz2
net-tools-2b17cc4fa2b31cd75021fa5c0222969643b0452a.zip
Provide local definition of IPPROTO_GRE to allow iptunnel
to build under glibc 2.0. Make it configurable whether iptunnel & ipmaddr are built, with the default being off. This seems to be necessary since making them work with 2.0 looks hard. Does it sound reasonable?
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index cf6d887..bdd1a56 100644
--- a/Makefile
+++ b/Makefile
@@ -76,7 +76,12 @@
NET_LIB_PATH = lib
NET_LIB_NAME = net-tools
-PROGS = ifconfig hostname arp netstat route rarp slattach plipconfig iptunnel ipmaddr
+PROGS := ifconfig hostname arp netstat route rarp slattach plipconfig
+
+-include config.make
+ifeq ($(HAVE_IP_TOOLS),1)
+PROGS += iptunnel ipmaddr
+endif
# Compiler and Linker Options
# You may need to uncomment and edit these if you are using libc5 and IPv6.