summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/profi/profi-1.3.ebuild')
-rw-r--r--dev-lua/profi/profi-1.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-lua/profi/profi-1.3.ebuild b/dev-lua/profi/profi-1.3.ebuild
new file mode 100644
index 0000000..c16e67c
--- /dev/null
+++ b/dev-lua/profi/profi-1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GIST_A="perky"
+GIST_ID="2838755"
+GIST_SHA="78e573ca38b859c8639427c52d2c850736969bc7"
+
+inherit lua
+
+DESCRIPTION="a Lua Profiler"
+HOMEPAGE="https://gist.github.com/perky/2838755"
+SRC_URI="https://gist.github.com/${GIST_A}/${GIST_ID}/archive/${GIST_SHA}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc mips arm"
+IUSE=""
+
+LUA_S="${GIST_ID}-${GIST_SHA}"
+
+each_lua_install() {
+ dolua ProFi.lua
+}