summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/orbit/orbit-9999.ebuild')
-rw-r--r--dev-lua/orbit/orbit-9999.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/dev-lua/orbit/orbit-9999.ebuild b/dev-lua/orbit/orbit-9999.ebuild
index 072764e..c4ecc46 100644
--- a/dev-lua/orbit/orbit-9999.ebuild
+++ b/dev-lua/orbit/orbit-9999.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
+VCS="git"
+GITHUB_A="keplerproject"
-VCS="git-r3"
inherit lua
DESCRIPTION="MVC Web Framework for Lua"
HOMEPAGE="https://github.com/keplerproject/orbit"
-SRC_URI=""
-
-EGIT_REPO_URI="https://github.com/keplerproject/orbit.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="doc +examples"
+IUSE="doc examples"
RDEPEND="
dev-lua/wsapi
@@ -24,8 +23,8 @@ RDEPEND="
DEPEND="
${RDEPEND}
"
-DOCS=( doc/. )
-EXAMPLES=( samples/. test/. )
+DOCS=(doc/.)
+EXAMPLES=(samples/. test/.)
all_lua_prepare() {
sed -r \
@@ -35,10 +34,7 @@ all_lua_prepare() {
rm samples/pages/doc samples/doc
}
-src_configure() { :; }
-src_compile() { :; }
-
each_lua_install() {
dolua src/${PN}{,.lua}
- dobin src/launchers/${PN}
+ dobin src/launchers/*
}