summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lua-fann/lua-fann-9999.ebuild')
-rw-r--r--dev-lua/lua-fann/lua-fann-9999.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-lua/lua-fann/lua-fann-9999.ebuild b/dev-lua/lua-fann/lua-fann-9999.ebuild
index d8eac99..afaa59c 100644
--- a/dev-lua/lua-fann/lua-fann-9999.ebuild
+++ b/dev-lua/lua-fann/lua-fann-9999.ebuild
@@ -1,22 +1,21 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
+VCS="git"
+IS_MULTILIB=true
+GITHUB_A="msva"
-# fixme when fann will be multilib
-#IS_MULTILIB=true
-VCS="git-r3"
inherit lua
DESCRIPTION="A set of Lua bindings for the Fast Artificial Neural Network (FANN) library."
HOMEPAGE="https://github.com/msva/lua-fann"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/msva/${PN}"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS=""
-IUSE="doc +examples"
+IUSE="doc examples"
RDEPEND="
sci-mathematics/fann
@@ -25,9 +24,9 @@ DEPEND="
${RDEPEND}
"
-READMES=( README.md TODO )
-HTML_DOCS=( doc/luafann.html )
-EXAMPLES=( test/. )
+DOCS=(README.md)
+HTML_DOCS=(doc/luafann.html)
+EXAMPLES=(test/.)
all_lua_compile() {
touch .lua_eclass_config