summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2014-08-16 16:58:11 +0700
committerVadim A. Misbakh-Soloviov <mva@mva.name>2014-08-16 16:58:11 +0700
commit424669b9f81b51cc454040e103b062c30e99c880 (patch)
treeca93a55c36ce4da2dc12e7a637f3290d991f74ae /dev-lua
parent[dev-lua/resty-sendmail] added (diff)
downloadlua-424669b9f81b51cc454040e103b062c30e99c880.tar.gz
lua-424669b9f81b51cc454040e103b062c30e99c880.tar.bz2
lua-424669b9f81b51cc454040e103b062c30e99c880.zip
[dev-lua/resty*] OpenResty bumps, additions, fixes
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/rds-parser/rds-parser-0.05.ebuild38
-rw-r--r--dev-lua/rds-parser/rds-parser-9999.ebuild4
-rw-r--r--dev-lua/redis-parser/redis-parser-0.10.ebuild38
-rw-r--r--dev-lua/redis-parser/redis-parser-9999.ebuild4
-rw-r--r--dev-lua/resty-core/Manifest1
-rw-r--r--dev-lua/resty-core/metadata.xml14
-rw-r--r--dev-lua/resty-core/resty-core-9999.ebuild (renamed from dev-lua/resty-lock/resty-lock-0.01.ebuild)15
-rw-r--r--dev-lua/resty-dns/resty-dns-0.10.ebuild39
-rw-r--r--dev-lua/resty-dns/resty-dns-9999.ebuild4
-rw-r--r--dev-lua/resty-lock/resty-lock-9999.ebuild4
-rw-r--r--dev-lua/resty-lrucache/resty-lrucache-9999.ebuild4
-rw-r--r--dev-lua/resty-memcached/resty-memcached-0.12.ebuild39
-rw-r--r--dev-lua/resty-memcached/resty-memcached-9999.ebuild4
-rw-r--r--dev-lua/resty-mysql/resty-mysql-0.14.ebuild39
-rw-r--r--dev-lua/resty-mysql/resty-mysql-9999.ebuild4
-rw-r--r--dev-lua/resty-redis/resty-redis-0.17.ebuild39
-rw-r--r--dev-lua/resty-redis/resty-redis-9999.ebuild4
-rw-r--r--dev-lua/resty-string/resty-string-9999.ebuild4
-rw-r--r--dev-lua/resty-upload/resty-upload-0.09.ebuild39
-rw-r--r--dev-lua/resty-upload/resty-upload-9999.ebuild4
-rw-r--r--dev-lua/resty-upstream-healthcheck/Manifest1
-rw-r--r--dev-lua/resty-upstream-healthcheck/metadata.xml14
-rw-r--r--dev-lua/resty-upstream-healthcheck/resty-upstream-healthcheck-9999.ebuild (renamed from dev-lua/resty-string/resty-string-0.08.ebuild)18
-rw-r--r--dev-lua/resty-websocket/resty-websocket-0.02.ebuild39
-rw-r--r--dev-lua/resty-websocket/resty-websocket-9999.ebuild4
25 files changed, 68 insertions, 349 deletions
diff --git a/dev-lua/rds-parser/rds-parser-0.05.ebuild b/dev-lua/rds-parser/rds-parser-0.05.ebuild
deleted file mode 100644
index 3c2a725..0000000
--- a/dev-lua/rds-parser/rds-parser-0.05.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: This ebuild is from Lua overlay; Bumped by mva; $
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Resty-DBD-Stream (RDS) parser for Lua written in C"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
-SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE="luajit"
-
-RDEPEND="
- !luajit? ( >=dev-lang/lua-5.1 )
- luajit? ( dev-lang/luajit:2 )
-"
-DEPEND="
- ${RDEPEND}
- dev-util/pkgconfig
-"
-
-S="${WORKDIR}/lua-${P}"
-
-src_prepare() {
- local lua=lua;
- use luajit && lua=luajit;
-
- sed -r \
- -e "1,6s#(PREFIX).*#\1=/usr#" \
- -e "1,6s#(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
- -e "1,6s#(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
- -i Makefile
-}
diff --git a/dev-lua/rds-parser/rds-parser-9999.ebuild b/dev-lua/rds-parser/rds-parser-9999.ebuild
index a70b737..738f672 100644
--- a/dev-lua/rds-parser/rds-parser-9999.ebuild
+++ b/dev-lua/rds-parser/rds-parser-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Resty-DBD-Stream (RDS) parser for Lua written in C"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-lua/redis-parser/redis-parser-0.10.ebuild b/dev-lua/redis-parser/redis-parser-0.10.ebuild
deleted file mode 100644
index 124906a..0000000
--- a/dev-lua/redis-parser/redis-parser-0.10.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: This ebuild is from Lua overlay; Bumped by mva; $
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Redis reply parser and request constructor library for Lua"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
-SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE="luajit"
-
-RDEPEND="
- !luajit? ( >=dev-lang/lua-5.1 )
- luajit? ( dev-lang/luajit:2 )
-"
-DEPEND="
- ${RDEPEND}
- dev-util/pkgconfig
-"
-
-S="${WORKDIR}/lua-${P}"
-
-src_prepare() {
- local lua=lua;
- use luajit && lua=luajit;
-
- sed -r \
- -e "1,6s#(PREFIX).*#\1=/usr#" \
- -e "1,6s#(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
- -e "1,6s#(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
- -i Makefile
-}
diff --git a/dev-lua/redis-parser/redis-parser-9999.ebuild b/dev-lua/redis-parser/redis-parser-9999.ebuild
index 550315a..315c46f 100644
--- a/dev-lua/redis-parser/redis-parser-9999.ebuild
+++ b/dev-lua/redis-parser/redis-parser-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Redis reply parser and request constructor library for Lua"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-lua/resty-core/Manifest b/dev-lua/resty-core/Manifest
new file mode 100644
index 0000000..6132373
--- /dev/null
+++ b/dev-lua/resty-core/Manifest
@@ -0,0 +1 @@
+DIST resty-string-0.08.tar.gz 9284 SHA256 45bc178f3541f2c77c262a2fa0e7856191d3e725bffcb2df03504adc99a15f15 SHA512 a4cbb4a4990190a0eb5b51a397656e0ad0ae491e76f09ff8b0d3feb27160589c80e0d40983b0ce3d5e3f526f8080cf3706522684b316a1d4bd0b3f1d39ff8551 WHIRLPOOL 4c80fb7f5343e51e70d74dc12ce99e1f62c75e1b88445cf3c099315c3e3045f4e31271936bc283aebc8ec3c010649a9da868dc27600bbed163be39cd514ba5c3
diff --git a/dev-lua/resty-core/metadata.xml b/dev-lua/resty-core/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/dev-lua/resty-core/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/dev-lua/resty-lock/resty-lock-0.01.ebuild b/dev-lua/resty-core/resty-core-9999.ebuild
index 56479e0..d43e3e3 100644
--- a/dev-lua/resty-lock/resty-lock-0.01.ebuild
+++ b/dev-lua/resty-core/resty-core-9999.ebuild
@@ -4,28 +4,29 @@
EAPI="5"
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs git-r3
-DESCRIPTION="Simple shm-based nonblocking lock API"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
-SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="New LuaJIT FFI based API for lua-nginx-module"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 amd64"
+KEYWORDS=""
IUSE=""
RDEPEND="
dev-lang/luajit:2
www-servers/nginx[nginx_modules_http_lua]
+ dev-lua/resty-lrucache
"
DEPEND="
${RDEPEND}
dev-util/pkgconfig
"
-S="${WORKDIR}/lua-${P}"
-
src_prepare() {
local lua=luajit;
diff --git a/dev-lua/resty-dns/resty-dns-0.10.ebuild b/dev-lua/resty-dns/resty-dns-0.10.ebuild
deleted file mode 100644
index 1001da5..0000000
--- a/dev-lua/resty-dns/resty-dns-0.10.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: This ebuild is from Lua overlay; Bumped by mva; $
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Lua DNS resolver for the ngx_lua based on the cosocket API"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
-SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE="luajit"
-
-RDEPEND="
- !luajit? ( >=dev-lang/lua-5.1 dev-lua/LuaBitOp )
- luajit? ( dev-lang/luajit:2 )
- www-servers/nginx[nginx_modules_http_lua]
-"
-DEPEND="
- ${RDEPEND}
- dev-util/pkgconfig
-"
-
-S="${WORKDIR}/lua-${P}"
-
-src_prepare() {
- local lua=lua;
- use luajit && lua=luajit;
-
- sed -r \
- -e "1,6s#(PREFIX).*#\1=/usr#" \
- -e "1,6s#(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
- -e "1,6s#(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
- -i Makefile
-}
diff --git a/dev-lua/resty-dns/resty-dns-9999.ebuild b/dev-lua/resty-dns/resty-dns-9999.ebuild
index d858225..3867656 100644
--- a/dev-lua/resty-dns/resty-dns-9999.ebuild
+++ b/dev-lua/resty-dns/resty-dns-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Lua DNS resolver for the ngx_lua based on the cosocket API"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-lua/resty-lock/resty-lock-9999.ebuild b/dev-lua/resty-lock/resty-lock-9999.ebuild
index 0f202f6..ff89a43 100644
--- a/dev-lua/resty-lock/resty-lock-9999.ebuild
+++ b/dev-lua/resty-lock/resty-lock-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Simple shm-based nonblocking lock API"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-lua/resty-lrucache/resty-lrucache-9999.ebuild b/dev-lua/resty-lrucache/resty-lrucache-9999.ebuild
index b2c112f..0f6d17f 100644
--- a/dev-lua/resty-lrucache/resty-lrucache-9999.ebuild
+++ b/dev-lua/resty-lrucache/resty-lrucache-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="A simple LRU cache for OpenResty and the ngx_lua module (based on LuaJIT FFI)"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-lua/resty-memcached/resty-memcached-0.12.ebuild b/dev-lua/resty-memcached/resty-memcached-0.12.ebuild
deleted file mode 100644
index 1fd9d56..0000000
--- a/dev-lua/resty-memcached/resty-memcached-0.12.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: This ebuild is from Lua overlay; Bumped by mva; $
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Lua memcached client driver for the ngx_lua based on the cosocket API"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
-SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE="luajit"
-
-RDEPEND="
- !luajit? ( >=dev-lang/lua-5.1 )
- luajit? ( dev-lang/luajit:2 )
- www-servers/nginx[nginx_modules_http_lua]
-"
-DEPEND="
- ${RDEPEND}
- dev-util/pkgconfig
-"
-
-S="${WORKDIR}/lua-${P}"
-
-src_prepare() {
- local lua=lua;
- use luajit && lua=luajit;
-
- sed -r \
- -e "1,6s#(PREFIX).*#\1=/usr#" \
- -e "1,6s#(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
- -e "1,6s#(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
- -i Makefile
-}
diff --git a/dev-lua/resty-memcached/resty-memcached-9999.ebuild b/dev-lua/resty-memcached/resty-memcached-9999.ebuild
index bd7c337..c1814cd 100644
--- a/dev-lua/resty-memcached/resty-memcached-9999.ebuild
+++ b/dev-lua/resty-memcached/resty-memcached-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Lua memcached client driver for the ngx_lua based on the cosocket API"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-lua/resty-mysql/resty-mysql-0.14.ebuild b/dev-lua/resty-mysql/resty-mysql-0.14.ebuild
deleted file mode 100644
index f7d7fd3..0000000
--- a/dev-lua/resty-mysql/resty-mysql-0.14.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: This ebuild is from Lua overlay; Bumped by mva; $
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Lua MySQL client driver for ngx_lua based on the cosocket API"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
-SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE="luajit"
-
-RDEPEND="
- !luajit? ( >=dev-lang/lua-5.1 dev-lua/LuaBitOp )
- luajit? ( dev-lang/luajit:2 )
- www-servers/nginx[nginx_modules_http_lua]
-"
-DEPEND="
- ${RDEPEND}
- dev-util/pkgconfig
-"
-
-S="${WORKDIR}/lua-${P}"
-
-src_prepare() {
- local lua=lua;
- use luajit && lua=luajit;
-
- sed -r \
- -e "1,6s#(PREFIX).*#\1=/usr#" \
- -e "1,6s#(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
- -e "1,6s#(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
- -i Makefile
-}
diff --git a/dev-lua/resty-mysql/resty-mysql-9999.ebuild b/dev-lua/resty-mysql/resty-mysql-9999.ebuild
index b2db3b1..c857cb1 100644
--- a/dev-lua/resty-mysql/resty-mysql-9999.ebuild
+++ b/dev-lua/resty-mysql/resty-mysql-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Lua MySQL client driver for ngx_lua based on the cosocket API"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-lua/resty-redis/resty-redis-0.17.ebuild b/dev-lua/resty-redis/resty-redis-0.17.ebuild
deleted file mode 100644
index e0fee68..0000000
--- a/dev-lua/resty-redis/resty-redis-0.17.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: This ebuild is from Lua overlay; Bumped by mva; $
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Lua redis client driver for the ngx_lua based on the cosocket API"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
-SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE="luajit"
-
-RDEPEND="
- !luajit? ( >=dev-lang/lua-5.1 )
- luajit? ( dev-lang/luajit:2 )
- www-servers/nginx[nginx_modules_http_lua]
-"
-DEPEND="
- ${RDEPEND}
- dev-util/pkgconfig
-"
-
-S="${WORKDIR}/lua-${P}"
-
-src_prepare() {
- local lua=lua;
- use luajit && lua=luajit;
-
- sed -r \
- -e "1,6s#(PREFIX).*#\1=/usr#" \
- -e "1,6s#(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
- -e "1,6s#(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
- -i Makefile
-}
diff --git a/dev-lua/resty-redis/resty-redis-9999.ebuild b/dev-lua/resty-redis/resty-redis-9999.ebuild
index 8a8c0e9..86a079b 100644
--- a/dev-lua/resty-redis/resty-redis-9999.ebuild
+++ b/dev-lua/resty-redis/resty-redis-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Lua redis client driver for the ngx_lua based on the cosocket API"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-lua/resty-string/resty-string-9999.ebuild b/dev-lua/resty-string/resty-string-9999.ebuild
index 6e249b2..540ffc7 100644
--- a/dev-lua/resty-string/resty-string-9999.ebuild
+++ b/dev-lua/resty-string/resty-string-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="String utilities and common hash functions for ngx_lua and LuaJIT"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-lua/resty-upload/resty-upload-0.09.ebuild b/dev-lua/resty-upload/resty-upload-0.09.ebuild
deleted file mode 100644
index f6d2344..0000000
--- a/dev-lua/resty-upload/resty-upload-0.09.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: This ebuild is from Lua overlay; Bumped by mva; $
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Streaming reader and parser for HTTP file uploading based on ngx_lua cosocket"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
-SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE="luajit"
-
-RDEPEND="
- !luajit? ( >=dev-lang/lua-5.1 )
- luajit? ( dev-lang/luajit:2 )
- www-servers/nginx[nginx_modules_http_lua]
-"
-DEPEND="
- ${RDEPEND}
- dev-util/pkgconfig
-"
-
-S="${WORKDIR}/lua-${P}"
-
-src_prepare() {
- local lua=lua;
- use luajit && lua=luajit;
-
- sed -r \
- -e "1,6s#(PREFIX).*#\1=/usr#" \
- -e "1,6s#(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
- -e "1,6s#(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
- -i Makefile
-}
diff --git a/dev-lua/resty-upload/resty-upload-9999.ebuild b/dev-lua/resty-upload/resty-upload-9999.ebuild
index 1a6c748..2b7d2a1 100644
--- a/dev-lua/resty-upload/resty-upload-9999.ebuild
+++ b/dev-lua/resty-upload/resty-upload-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Streaming reader and parser for HTTP file uploading based on ngx_lua cosocket"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-lua/resty-upstream-healthcheck/Manifest b/dev-lua/resty-upstream-healthcheck/Manifest
new file mode 100644
index 0000000..6132373
--- /dev/null
+++ b/dev-lua/resty-upstream-healthcheck/Manifest
@@ -0,0 +1 @@
+DIST resty-string-0.08.tar.gz 9284 SHA256 45bc178f3541f2c77c262a2fa0e7856191d3e725bffcb2df03504adc99a15f15 SHA512 a4cbb4a4990190a0eb5b51a397656e0ad0ae491e76f09ff8b0d3feb27160589c80e0d40983b0ce3d5e3f526f8080cf3706522684b316a1d4bd0b3f1d39ff8551 WHIRLPOOL 4c80fb7f5343e51e70d74dc12ce99e1f62c75e1b88445cf3c099315c3e3045f4e31271936bc283aebc8ec3c010649a9da868dc27600bbed163be39cd514ba5c3
diff --git a/dev-lua/resty-upstream-healthcheck/metadata.xml b/dev-lua/resty-upstream-healthcheck/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/dev-lua/resty-upstream-healthcheck/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/dev-lua/resty-string/resty-string-0.08.ebuild b/dev-lua/resty-upstream-healthcheck/resty-upstream-healthcheck-9999.ebuild
index 745484d..1a802f4 100644
--- a/dev-lua/resty-string/resty-string-0.08.ebuild
+++ b/dev-lua/resty-upstream-healthcheck/resty-upstream-healthcheck-9999.ebuild
@@ -4,29 +4,27 @@
EAPI="5"
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs git-r3
-DESCRIPTION="String utilities and common hash functions for ngx_lua and LuaJIT"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
-SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Health Checker for Nginx Upstream Servers in Pure Lua"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 amd64"
+KEYWORDS=""
IUSE=""
RDEPEND="
- dev-lang/luajit:2
- www-servers/nginx[nginx_modules_http_lua]
- dev-libs/openssl
+ www-servers/nginx[nginx_modules_http_lua,nginx_modules_http_lua_upsteam]
"
DEPEND="
${RDEPEND}
dev-util/pkgconfig
"
-S="${WORKDIR}/lua-${P}"
-
src_prepare() {
local lua=luajit;
diff --git a/dev-lua/resty-websocket/resty-websocket-0.02.ebuild b/dev-lua/resty-websocket/resty-websocket-0.02.ebuild
deleted file mode 100644
index 0184531..0000000
--- a/dev-lua/resty-websocket/resty-websocket-0.02.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: This ebuild is from Lua overlay; Bumped by mva; $
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Lua WebSocket implementation for the NginX lua module"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
-SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE="luajit"
-
-RDEPEND="
- !luajit? ( >=dev-lang/lua-5.1 )
- luajit? ( dev-lang/luajit:2 )
- www-servers/nginx[nginx_modules_http_lua]
-"
-DEPEND="
- ${RDEPEND}
- dev-util/pkgconfig
-"
-
-S="${WORKDIR}/lua-${P}"
-
-src_prepare() {
- local lua=lua;
- use luajit && lua=luajit;
-
- sed -r \
- -e "1,6s#(PREFIX).*#\1=/usr#" \
- -e "1,6s#(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
- -e "1,6s#(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
- -i Makefile
-}
diff --git a/dev-lua/resty-websocket/resty-websocket-9999.ebuild b/dev-lua/resty-websocket/resty-websocket-9999.ebuild
index 9c5a6c1..27a273d 100644
--- a/dev-lua/resty-websocket/resty-websocket-9999.ebuild
+++ b/dev-lua/resty-websocket/resty-websocket-9999.ebuild
@@ -7,10 +7,10 @@ EAPI="5"
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Lua WebSocket implementation for the NginX lua module"
-HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+HOMEPAGE="https://github.com/openresty/lua-${PN}"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+EGIT_REPO_URI="https://github.com/openresty/lua-${PN}"
LICENSE="BSD"
SLOT="0"