summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2013-12-17 14:00:42 +0700
committerVadim A. Misbakh-Soloviov <mva@mva.name>2013-12-17 14:00:42 +0700
commit38c1125b284c8d3afbb2bb5e6207467dfd51e61d (patch)
tree454d4abd1a2a530a0c1270e098d59290229a063e /dev-lua/resty-string
parent[net-im/prosody-modules] bump modules (diff)
downloadlua-38c1125b284c8d3afbb2bb5e6207467dfd51e61d.tar.gz
lua-38c1125b284c8d3afbb2bb5e6207467dfd51e61d.tar.bz2
lua-38c1125b284c8d3afbb2bb5e6207467dfd51e61d.zip
[dev-lua/resty-*] Added
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'dev-lua/resty-string')
-rw-r--r--dev-lua/resty-string/Manifest1
-rw-r--r--dev-lua/resty-string/metadata.xml14
-rw-r--r--dev-lua/resty-string/resty-string-0.08.ebuild38
-rw-r--r--dev-lua/resty-string/resty-string-9999.ebuild38
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-lua/resty-string/Manifest b/dev-lua/resty-string/Manifest
new file mode 100644
index 0000000..6132373
--- /dev/null
+++ b/dev-lua/resty-string/Manifest
@@ -0,0 +1 @@
+DIST resty-string-0.08.tar.gz 9284 SHA256 45bc178f3541f2c77c262a2fa0e7856191d3e725bffcb2df03504adc99a15f15 SHA512 a4cbb4a4990190a0eb5b51a397656e0ad0ae491e76f09ff8b0d3feb27160589c80e0d40983b0ce3d5e3f526f8080cf3706522684b316a1d4bd0b3f1d39ff8551 WHIRLPOOL 4c80fb7f5343e51e70d74dc12ce99e1f62c75e1b88445cf3c099315c3e3045f4e31271936bc283aebc8ec3c010649a9da868dc27600bbed163be39cd514ba5c3
diff --git a/dev-lua/resty-string/metadata.xml b/dev-lua/resty-string/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/dev-lua/resty-string/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/dev-lua/resty-string/resty-string-0.08.ebuild b/dev-lua/resty-string/resty-string-0.08.ebuild
new file mode 100644
index 0000000..745484d
--- /dev/null
+++ b/dev-lua/resty-string/resty-string-0.08.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="String utilities and common hash functions for ngx_lua and LuaJIT"
+HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+SRC_URI="https://github.com/agentzh/lua-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/luajit:2
+ www-servers/nginx[nginx_modules_http_lua]
+ dev-libs/openssl
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+S="${WORKDIR}/lua-${P}"
+
+src_prepare() {
+ local lua=luajit;
+
+ sed -r \
+ -e "1,6s#(PREFIX).*#\1=/usr#" \
+ -e "1,6s#(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
+ -e "1,6s#(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
+ -i Makefile
+}
diff --git a/dev-lua/resty-string/resty-string-9999.ebuild b/dev-lua/resty-string/resty-string-9999.ebuild
new file mode 100644
index 0000000..6e249b2
--- /dev/null
+++ b/dev-lua/resty-string/resty-string-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs git-r3
+
+DESCRIPTION="String utilities and common hash functions for ngx_lua and LuaJIT"
+HOMEPAGE="https://github.com/agentzh/lua-${PN}"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/agentzh/lua-${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ dev-lang/luajit:2
+ www-servers/nginx[nginx_modules_http_lua]
+ dev-libs/openssl
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+src_prepare() {
+ local lua=luajit;
+
+ sed -r \
+ -e "1,6s#(PREFIX).*#\1=/usr#" \
+ -e "1,6s#(LUA_LIB_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})#" \
+ -e "1,6s#(LUA_INCLUDE_DIR).*#\1=$($(tc-getPKG_CONFIG) --variable includedir ${lua})#" \
+ -i Makefile
+}