summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/strace/strace-4.5.19.ebuild')
-rw-r--r--dev-util/strace/strace-4.5.19.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/strace/strace-4.5.19.ebuild b/dev-util/strace/strace-4.5.19.ebuild
new file mode 100644
index 0000000..c809253
--- /dev/null
+++ b/dev-util/strace/strace-4.5.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.19.ebuild,v 1.3 2009/11/11 21:11:20 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static aio"
+
+# strace only uses the header from libaio
+DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-mips-n32.patch"
+}
+
+src_compile() {
+ filter-lfs-flags # configure handles this sanely
+ use static && append-ldflags -static
+
+ use aio || export ac_cv_header_libaio_h=no #
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog CREDITS NEWS PORTING README* TODO
+}