summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStelian Ionescu <sionescu@cddr.org>2011-01-31 12:57:08 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2018-03-09 22:33:29 +0100
commitb05c18364e053b327eb1a69d24531fc2722eb1b6 (patch)
treef58d679b8e0506f70fcba9280541bb0285f49447 /dev-lisp/local-time
parentdev-lisp/closure-html: bump to version 20100920 (diff)
downloadlisp-b05c18364e053b327eb1a69d24531fc2722eb1b6.tar.gz
lisp-b05c18364e053b327eb1a69d24531fc2722eb1b6.tar.bz2
lisp-b05c18364e053b327eb1a69d24531fc2722eb1b6.zip
dev-lisp/local-time: bump to version 1.0.1_p20100617
Diffstat (limited to 'dev-lisp/local-time')
-rw-r--r--dev-lisp/local-time/Manifest5
-rw-r--r--dev-lisp/local-time/files/1.0.1_p20100617-gentoo-use-system-zonedata.patch27
-rw-r--r--dev-lisp/local-time/local-time-1.0.1_p20100617.ebuild (renamed from dev-lisp/local-time/local-time-1.0.1.ebuild)23
3 files changed, 45 insertions, 10 deletions
diff --git a/dev-lisp/local-time/Manifest b/dev-lisp/local-time/Manifest
index 9d823e6e..269648ec 100644
--- a/dev-lisp/local-time/Manifest
+++ b/dev-lisp/local-time/Manifest
@@ -1,2 +1,3 @@
-DIST local-time-1.0.1.tar.gz 271457 RMD160 d3fe87a7b95ad5b80ea89ffbde4da3e303bfa5ba SHA1 43e67dd41428ea66054162e91eee5f2bfd3e180c SHA256 bf0d4a2d114028578fc0198fa76f03576763d5c99690019cd27af238544d548b
-EBUILD local-time-1.0.1.ebuild 987 RMD160 38719b69b5609ff96f13eb9f6bab17e9b6c61207 SHA1 4faa10011d2d0706be8e93c84f8b7f5be056a295 SHA256 2e55bca0fae61755fabff892bb1c301f63933c1cef0ea69bf0690c44495c089d
+AUX 1.0.1_p20100617-gentoo-use-system-zonedata.patch 1234 RMD160 5cfd2154bbade3234b648e59d3569dfaaf64d84c SHA1 f62c082ff4e00816c171f897b9c0115cff787f0b SHA256 f40fffc0fce86c879ecc267620651769a6fa50c71672272f84afdb1008c2b414
+DIST local-time-1.0.1_p20100617.tar.gz 38838 RMD160 56d81a694bfe890ddc2f27b863f4c8ad1a060c5b SHA1 52e4dd9795553236cfae5090d2389585733db12e SHA256 46631c0595bb724f1c92282e13858d0d0b8040eb573b8ae2e1873074909c6287
+EBUILD local-time-1.0.1_p20100617.ebuild 1250 RMD160 75e353c6d2afcdb71134fccb3d53f31f8ebebfa7 SHA1 d90a035114989138bb9d36cd9fedc305d9334415 SHA256 27a64c8262f99caf35a00972e92b71bd69baa68ce0676a28c42b91dfc2c1f3dc
diff --git a/dev-lisp/local-time/files/1.0.1_p20100617-gentoo-use-system-zonedata.patch b/dev-lisp/local-time/files/1.0.1_p20100617-gentoo-use-system-zonedata.patch
new file mode 100644
index 00000000..9e5d5f75
--- /dev/null
+++ b/dev-lisp/local-time/files/1.0.1_p20100617-gentoo-use-system-zonedata.patch
@@ -0,0 +1,27 @@
+diff -ur local-time-1.0.1_p20100617.orig/src/local-time.lisp local-time-1.0.1_p20100617/src/local-time.lisp
+--- local-time-1.0.1_p20100617.orig/src/local-time.lisp 2010-12-27 01:07:31.733466036 +0100
++++ local-time-1.0.1_p20100617/src/local-time.lisp 2011-01-31 12:21:18.795037693 +0100
+@@ -206,22 +206,7 @@
+ ;;; Variables
+
+ (defparameter *default-timezone-repository-path*
+- (flet ((try (project-home-directory)
+- (when project-home-directory
+- (ignore-errors
+- (truename
+- (merge-pathnames "zoneinfo/"
+- (make-pathname :directory (pathname-directory project-home-directory))))))))
+- (or (when (find-package "ASDF")
+- (let ((path (eval (read-from-string
+- "(let ((system (asdf:find-system :local-time nil)))
+- (when system
+- (asdf:component-pathname system)))"))))
+- (try path)))
+- (let ((path (or #.*compile-file-truename*
+- *load-truename*)))
+- (when path
+- (try (merge-pathnames "../" path)))))))
++ #p"/usr/share/zoneinfo/")
+
+ ;;; Month information
+ (defparameter +month-names+
diff --git a/dev-lisp/local-time/local-time-1.0.1.ebuild b/dev-lisp/local-time/local-time-1.0.1_p20100617.ebuild
index f8311de6..4b1a55c1 100644
--- a/dev-lisp/local-time/local-time-1.0.1.ebuild
+++ b/dev-lisp/local-time/local-time-1.0.1_p20100617.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit common-lisp-2
+EAPI=3
+inherit common-lisp-3
DESCRIPTION="LOCAL-TIME is a development library for manipulating date and time information."
HOMEPAGE="http://common-lisp.net/project/local-time/"
-SRC_URI="http://common-lisp.net/project/${PN}/${P}.tar.gz"
+SRC_URI="http://common-lisp.net/~sionescu/files/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -15,11 +16,13 @@ IUSE="doc postgres"
DEPEND="sys-apps/texinfo
doc? ( virtual/texi2dvi )"
-RDEPEND="dev-lisp/cl-fad
- dev-lisp/fiveam"
+RDEPEND="sys-libs/timezone-data
+ dev-lisp/cl-fad"
PDEPEND="postgres? ( dev-lisp/postmodern )"
-S="${WORKDIR}"/${PN}
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo-use-system-zonedata.patch
+}
src_compile() {
cd doc
@@ -31,8 +34,12 @@ src_compile() {
}
src_install() {
- common-lisp-install ${PN}.asd src zoneinfo
- common-lisp-symlink-asdf
+ common-lisp-install-sources src/local-time.lisp test
+ common-lisp-install-asdf local-time.asd local-time.test.asd
+ if use postgres; then
+ common-lisp-install-sources src/integration/cl-postgres.lisp
+ common-lisp-install-asdf cl-postgres+local-time.asd
+ fi
dodoc CREDITS README TODO
doinfo doc/${PN}.info
use doc && dodoc doc/${PN}.pdf