aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2011-07-07 10:35:48 +0800
committerMu Qiao <qiaomuf@gentoo.org>2011-07-20 23:08:30 +0800
commitc61ce956e4ffae69c34cf4e9448420d54d750047 (patch)
treebed8db7e18c1e4674566fd94d11718483c7b4e4a /Makefile.am
parentBuild: add antlr flags (diff)
downloadlibbash-c61ce956e4ffae69c34cf4e9448420d54d750047.tar.gz
libbash-c61ce956e4ffae69c34cf4e9448420d54d750047.tar.bz2
libbash-c61ce956e4ffae69c34cf4e9448420d54d750047.zip
Parser: remove global backtracking
Now several tests are not working: var_expansion.bash, isolated_functions.bash, compound_command.bash, test_expr.bash, test/ast_printer_test.sh, and test/verify_bashs_test.sh. We will fix them in later commits.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 20fe274..61041ec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,13 +48,9 @@ GUNIT_TESTS = bashast/gunit/arith_main.gunit \
BASH_LOG_COMPILER = $(srcdir)/test/bash_compiler.sh
BASH_TESTS = scripts/var_def.bash \
- scripts/var_expansion.bash \
scripts/command_execution.bash \
scripts/function_def.bash \
scripts/arithmetic_assignment.bash \
- scripts/isolated_functions.bash \
- scripts/compound_command.bash \
- scripts/test_expr.bash \
scripts/binary_arithmetic.bash
EBUILD_LOG_COMPILER = $(srcdir)/test/ebuild_compiler.sh
@@ -84,8 +80,6 @@ endif
if HAVE_GTEST
TESTS += cppunittests \
- test/ast_printer_test.sh \
- test/verify_bashs_test.sh \
test/verify_error_output_test.sh \
test/bash_result_tests.sh
check_PROGRAMS = cppunittests