aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-08 17:46:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-08 18:59:12 +0200
commit9e17794a7e157407c455b4d87ebe1b13716679ed (patch)
treede377c7559c21ea115cf74d4d3573efcad46e3ca /media-gfx
parentmedia-gfx/kio-mobi-thumbnailer: 24.08.2 version bump (diff)
downloadkde-9e17794a7e157407c455b4d87ebe1b13716679ed.tar.gz
kde-9e17794a7e157407c455b4d87ebe1b13716679ed.tar.bz2
kde-9e17794a7e157407c455b4d87ebe1b13716679ed.zip
media-gfx/kio-ps-thumbnailer: 24.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/kio-ps-thumbnailer/Manifest1
-rw-r--r--media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.08.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/kio-ps-thumbnailer/Manifest b/media-gfx/kio-ps-thumbnailer/Manifest
new file mode 100644
index 0000000000..4f11a9b596
--- /dev/null
+++ b/media-gfx/kio-ps-thumbnailer/Manifest
@@ -0,0 +1 @@
+DIST kdegraphics-thumbnailers-24.08.2.tar.xz 49096 BLAKE2B 3c6eddf3abe61ca55ffe04dda9e720be324078bf453b2c768ed001490e19b5c8df5d4904c14d4f82a96d9fc669cae5956f673a6aa81591044fa8f40695e594eb SHA512 0d9c536865702e0e1962cf7405373a2166656f9b63fdd03128000b2aac01fceceb1b9ddea041fbc6c66d79a744b76575929896fe1614b060941eb56ae69fa0f1
diff --git a/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.08.2.ebuild b/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.08.2.ebuild
new file mode 100644
index 0000000000..e0ab877271
--- /dev/null
+++ b/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.08.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="KIO thumbnail generator for DVI, EPS, PDF and PS files"
+HOMEPAGE="https://apps.kde.org/kdegraphics_thumbnailers/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=kde-frameworks/kio-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/thumbnailers-24.05.2-r1:6
+ app-text/dvipsk
+ app-text/ghostscript-gpl
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module Archive
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_blend=OFF
+ -DDISABLE_MOBIPOCKET=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_QMobipocket6=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KExiv2Qt6=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KDcrawQt6=ON
+ )
+
+ ecm_src_configure
+}