aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-01 09:52:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-01 09:52:29 +0200
commitc07b427c8133a4207e9cb15264853c5bc676d0ad (patch)
tree429270873e69fa6a5581b4ebfc73702283925abe /kde-apps/pim-data-exporter
parentkde-apps/messagelib: 20.08.1 version bump (diff)
downloadkde-c07b427c8133a4207e9cb15264853c5bc676d0ad.tar.gz
kde-c07b427c8133a4207e9cb15264853c5bc676d0ad.tar.bz2
kde-c07b427c8133a4207e9cb15264853c5bc676d0ad.zip
kde-apps/pim-data-exporter: 20.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/pim-data-exporter')
-rw-r--r--kde-apps/pim-data-exporter/Manifest1
-rw-r--r--kde-apps/pim-data-exporter/pim-data-exporter-20.08.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/kde-apps/pim-data-exporter/Manifest b/kde-apps/pim-data-exporter/Manifest
new file mode 100644
index 0000000000..0c71eaf543
--- /dev/null
+++ b/kde-apps/pim-data-exporter/Manifest
@@ -0,0 +1 @@
+DIST pim-data-exporter-20.08.1.tar.xz 399256 BLAKE2B 625b4c36ffe49aab11451e648052d9892325fda4f158cd7a75e9bd7bd5598d0186b01f90b37144f14fbffc314b0fa169b8e55eed2be2391cdc6968f8d4f67976 SHA512 279e006bb4347b1603aecf1f3bd6f424668af52e6b7fbc3c662b21b957c68dec169c3a5d8dbec799b1254cf02d5c90741e3b745dbad4f5afd16d5f111e0089b8
diff --git a/kde-apps/pim-data-exporter/pim-data-exporter-20.08.1.ebuild b/kde-apps/pim-data-exporter/pim-data-exporter-20.08.1.ebuild
new file mode 100644
index 0000000000..6121fb8a0a
--- /dev/null
+++ b/kde-apps/pim-data-exporter/pim-data-exporter-20.08.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.72.0
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Assistant to backup and archive PIM data and configuration"
+HOMEPAGE="https://kde.org/applications/internet/org.kde.pimdataexporter
+https://userbase.kde.org/KMail/Backup_Options"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="telemetry"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/mailcommon-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ telemetry? ( dev-libs/kuserfeedback:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package telemetry KUserFeedback)
+ )
+
+ ecm_src_configure
+}