aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-25 11:00:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-25 11:00:41 +0100
commit78766f7a94d023aac1ca2b4da8009ed78c385858 (patch)
tree74beace01e18c822e7576816eb5ade4e9c89f380 /kde-apps/kimap
parentkde-apps/kidentitymanagement: 22.03.80 version bump (diff)
downloadkde-78766f7a94d023aac1ca2b4da8009ed78c385858.tar.gz
kde-78766f7a94d023aac1ca2b4da8009ed78c385858.tar.bz2
kde-78766f7a94d023aac1ca2b4da8009ed78c385858.zip
kde-apps/kimap: 22.03.80 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kimap')
-rw-r--r--kde-apps/kimap/Manifest1
-rw-r--r--kde-apps/kimap/kimap-22.03.80.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/kimap/Manifest b/kde-apps/kimap/Manifest
new file mode 100644
index 0000000000..b00f120caf
--- /dev/null
+++ b/kde-apps/kimap/Manifest
@@ -0,0 +1 @@
+DIST kimap-22.03.80.tar.xz 130024 BLAKE2B 145c4fa5a545616af6f31c6e6dd37505e276f4928466b425dbee7f7b34580c90f2eabc9e483df638ce260d9563b0a7df1086d3b1b37baf2ba682f5a4132f504f SHA512 e9f36cbe234c6f41f9e0ee9b48f36cfe2591910daba2494c226f8c4d1267efd8663510b2d6521d87e785718fc125e3b6c89763fa5a8ab304039ab872c2853939
diff --git a/kde-apps/kimap/kimap-22.03.80.ebuild b/kde-apps/kimap/kimap-22.03.80.ebuild
new file mode 100644
index 0000000000..f885a79794
--- /dev/null
+++ b/kde-apps/kimap/kimap-22.03.80.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.92.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Library for interacting with IMAP servers"
+HOMEPAGE="https://api.kde.org/kdepim/kimap/html/index.html"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/cyrus-sasl
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+"
+# TODO: Convince upstream not to install stuff with tests
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtnetwork-${QTMIN}:5 )
+"
+
+src_test() {
+ # tests cannot be run in parallel #605586
+ local myctestargs=(
+ -j1
+ )
+ ecm_src_test
+}