aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-13 22:04:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-13 22:13:47 +0100
commit3f1a31ace937ce39a5f2e07f9f4013d6ebb56551 (patch)
tree5aeabc4723b8cd768a6e2e7a95e00c09ec583cb2 /dev-libs
parentapp-office/merkuro: 23.08.5 version bump (diff)
downloadkde-3f1a31ace937ce39a5f2e07f9f4013d6ebb56551.tar.gz
kde-3f1a31ace937ce39a5f2e07f9f4013d6ebb56551.tar.bz2
kde-3f1a31ace937ce39a5f2e07f9f4013d6ebb56551.zip
dev-libs/kopeninghours: 23.08.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-23.08.5.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index c37fa44904..3c98b3da69 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1 +1,2 @@
+DIST kopeninghours-23.08.5.tar.xz 72568 BLAKE2B 84e418d95f4a7261786a101882000bed0ca721931cc419e0330edb0f659e38459063d49c75ca643d169e9326ed66694130cfeebef51183c89e02efd02f6f3133 SHA512 a95cd3c446699d8bd95f2f746cb8b4187c7d2027067e5c731afe371a3313a5569780110e8acbf52d125da673aff4b2567da9f2b8c07a4412cf1d7540baad7a14
DIST kopeninghours-24.01.95.tar.xz 72700 BLAKE2B 90de4258b2be2790bcf4bbbd38b4afa81cc4090d1806f733f6af68a3ae231469bd6cb3c9e8d61460c446e973f325675c5e27646aa62dccb4bf1200b15a90d6a2 SHA512 f33bc44ca60f84ffde3ddfc9506ce4a37f6c211168d2a640e791e74f3336813c59d663781a78ebc04fb47c7d8cb7058416b8b1c267415cb3473eb7bb72f18423
diff --git a/dev-libs/kopeninghours/kopeninghours-23.08.5.ebuild b/dev-libs/kopeninghours/kopeninghours-23.08.5.ebuild
new file mode 100644
index 0000000000..0ced49ce9b
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-23.08.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.106.0
+QTMIN=5.15.9
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}