aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-11 00:17:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-11 00:26:20 +0200
commit6a79efadafe8419a9b4318e1e20ce0f8ee786b3c (patch)
tree1a3499e213d9657c1331c66f1d9f25c98aeea7eb /app-cdr
parentkde-apps/umbrello: 24.07.90 version bump (diff)
downloadkde-6a79efadafe8419a9b4318e1e20ce0f8ee786b3c.tar.gz
kde-6a79efadafe8419a9b4318e1e20ce0f8ee786b3c.tar.bz2
kde-6a79efadafe8419a9b4318e1e20ce0f8ee786b3c.zip
app-cdr/dolphin-plugins-mountiso: 24.07.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.07.90.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
new file mode 100644
index 0000000000..c0ca61b416
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -0,0 +1 @@
+DIST dolphin-plugins-24.07.90.tar.xz 316724 BLAKE2B a5f767042003744aa89af02f088e17004d02d95c8e37954a74fed6748938464e429fa63d6b027c419c22bbcfbccab1b6ae06cc8d52adc21fe2598c5ca7955b98 SHA512 3d23a33a22fa66025b198a5a312585527f8f06b2e265f80004ff772690a4e6dc33f7c9750b75a891eeb9cc6561827e3922757d976ad8b9de92747400663267c8
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.07.90.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.07.90.ebuild
new file mode 100644
index 0000000000..664c063265
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.07.90.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=6.5.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # qtconcurrent only required by git
+ ecm_punt_qt_module Concurrent
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}