aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-06 08:40:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-06 08:57:34 +0200
commit80ea62f9b9ff13e3fcb4381e7f263dd9badc2807 (patch)
treeed8b901dc84d3f2d501adfb2e95a49fe13fc687d
parentkde-apps/kidentitymanagement: 21.08.0 version bump (diff)
downloadkde-80ea62f9b9ff13e3fcb4381e7f263dd9badc2807.tar.gz
kde-80ea62f9b9ff13e3fcb4381e7f263dd9badc2807.tar.bz2
kde-80ea62f9b9ff13e3fcb4381e7f263dd9badc2807.zip
kde-apps/kimap: 21.08.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/kimap/Manifest1
-rw-r--r--kde-apps/kimap/kimap-21.08.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/kimap/Manifest b/kde-apps/kimap/Manifest
index 0b8114f16f..94f07dada1 100644
--- a/kde-apps/kimap/Manifest
+++ b/kde-apps/kimap/Manifest
@@ -1 +1,2 @@
DIST kimap-21.07.90.tar.xz 127480 BLAKE2B 53f010ba181ef2b9bd6352e952d9f6e5d815133b9b4a04dd3c2c06055beff6aa9cbfd5d61a716869029019237019310dac45054aa7ef8147ac141f7e485c0d99 SHA512 e8ad12d12abf7935163350987972b43f77d5d193ee32e3120dac4b3e5ad7fdf04c5d8285a3ce909e5aa106ece5090f7a1c2cca6b48b79a7d05b636071a3b1b04
+DIST kimap-21.08.0.tar.xz 127456 BLAKE2B b157d0da8b59ba0e2b5ab3e18d8b18bcf0b3058c4c6671b008a876d28c04047e48d57124738e55dc3a9d2f80378e9aa371f92f570c255cb8cc0f25e9d05b967d SHA512 997f28f3b55b2dc66aa6a3b70dc2d242a87b68014e001a20b93be9a4a140da31756b7e6890af4da28e4ca66ad8415d6c2133ab580da19fd0d7840c5063efd10f
diff --git a/kde-apps/kimap/kimap-21.08.0.ebuild b/kde-apps/kimap/kimap-21.08.0.ebuild
new file mode 100644
index 0000000000..e6b4c2bafe
--- /dev/null
+++ b/kde-apps/kimap/kimap-21.08.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.84.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Library for interacting with IMAP servers"
+HOMEPAGE="https://api.kde.org/kdepim/kimap/html/index.html"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/cyrus-sasl
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+"
+# TODO: Convince upstream not to install stuff with tests
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtnetwork-${QTMIN}:5 )
+"
+
+src_test() {
+ # tests cannot be run in parallel #605586
+ local myctestargs=(
+ -j1
+ )
+ ecm_src_test
+}