summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/SoQt/SoQt-1.3.0.ebuild')
-rw-r--r--media-libs/SoQt/SoQt-1.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/SoQt/SoQt-1.3.0.ebuild b/media-libs/SoQt/SoQt-1.3.0.ebuild
new file mode 100644
index 00000000..a32429c7
--- /dev/null
+++ b/media-libs/SoQt/SoQt-1.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/SoQt-1.3.0.ebuild,v 1.4 2008/12/15 19:05:07 angelos Exp $
+
+DESCRIPTION="the glue between Coin3D and Qt3"
+SRC_URI="ftp://ftp.coin3d.org/pub/coin/src/all/${P}.tar.gz"
+HOMEPAGE="http://www.coin3d.org/"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 PEL )"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="=x11-libs/qt-3*
+ >=media-libs/coin-2.4.4"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf --with-coin --disable-html-help $(use_enable doc html) htmldir=/usr/share/doc/${PF}/html
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README*
+}