summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild')
-rw-r--r--dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild b/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
new file mode 100644
index 00000000..2ff30ffd
--- /dev/null
+++ b/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-qt3-old/dbus-qt3-old-0.70.ebuild,v 1.15 2008/08/18 18:50:28 rbu Exp $
+
+inherit qt3
+
+DESCRIPTION="D-BUS Qt3 bindings compatible with old application API and new dbus"
+HOMEPAGE="http://freedesktop.org/wiki/Software/dbus"
+SRC_URI="http://www.kolumbus.fi/juuso.alasuutari/${P/-old}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=sys-apps/dbus-0.91"
+DEPEND="${RDEPEND}
+ =x11-libs/qt-3*"
+
+S=${WORKDIR}/${P/-old}
+
+src_compile() {
+ econf --enable-qt3 --with-qt3-moc=${QTDIR}/bin/moc \
+ $(use_enable debug qt-debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}