summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/ppp/files')
-rw-r--r--net-dialup/ppp/files/README.mpls15
-rw-r--r--net-dialup/ppp/files/modules.ppp10
-rw-r--r--net-dialup/ppp/files/ppp-2.4.7-dhcp-musl.patch44
-rw-r--r--net-dialup/ppp/files/ppp-2.4.7-musl.patch179
4 files changed, 0 insertions, 248 deletions
diff --git a/net-dialup/ppp/files/README.mpls b/net-dialup/ppp/files/README.mpls
deleted file mode 100644
index 1ae7ae46..00000000
--- a/net-dialup/ppp/files/README.mpls
+++ /dev/null
@@ -1,15 +0,0 @@
-MPLS consists of 3 components:
-1. MPLS forwarding
-2. MPLS signalling
-3. Mapping layer 3 traffic onto MPLS LSPs
-
-The document mpls-forwarding basics explains item 1.
-
-Examples of MPLS signalling protocols are: RSVP-TE LDP and CR-LDP.
-The package ldp-portable is an implementation of LDP and contains more
-information about LDP based MPLS signalling.
-
-Mapping of layer 3 traffic to MPLS LSPs is accomplised in a couple of
-different ways.
--Per FEC where FEC is an entry in the routing table
--Virtual interface that represents an LSP
diff --git a/net-dialup/ppp/files/modules.ppp b/net-dialup/ppp/files/modules.ppp
deleted file mode 100644
index e936041c..00000000
--- a/net-dialup/ppp/files/modules.ppp
+++ /dev/null
@@ -1,10 +0,0 @@
-alias char-major-108 ppp_generic
-alias /dev/ppp ppp_generic
-alias tty-ldisc-3 ppp_async
-alias tty-ldisc-13 n_hdlc
-alias tty-ldisc-14 ppp_synctty
-alias ppp-compress-18 ppp_mppe
-alias ppp-compress-21 bsd_comp
-alias ppp-compress-24 ppp_deflate
-alias ppp-compress-26 ppp_deflate
-alias net-pf-24 pppoe
diff --git a/net-dialup/ppp/files/ppp-2.4.7-dhcp-musl.patch b/net-dialup/ppp/files/ppp-2.4.7-dhcp-musl.patch
deleted file mode 100644
index 4830bfe3..00000000
--- a/net-dialup/ppp/files/ppp-2.4.7-dhcp-musl.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -ur ppp-2.4.7.orig/pppd/plugins/dhcp/clientpacket.c ppp-2.4.7/pppd/plugins/dhcp/clientpacket.c
---- ppp-2.4.7.orig/pppd/plugins/dhcp/clientpacket.c 2002-08-31 12:19:20.000000000 +0000
-+++ ppp-2.4.7/pppd/plugins/dhcp/clientpacket.c 2015-05-20 13:24:41.299978928 +0000
-@@ -205,9 +205,9 @@
-
- /* Make sure its the right packet for us, and that it passes sanity checks */
- if (packet.ip.protocol != IPPROTO_UDP || packet.ip.version != IPVERSION ||
-- packet.ip.ihl != sizeof(packet.ip) >> 2 || packet.udp.dest != htons(CLIENT_PORT) ||
-+ packet.ip.ihl != sizeof(packet.ip) >> 2 || packet.udp.uh_dport != htons(CLIENT_PORT) ||
- bytes > (int) sizeof(struct udp_dhcp_packet) ||
-- ntohs(packet.udp.len) != (short) (bytes - sizeof(packet.ip))) {
-+ ntohs(packet.udp.uh_ulen) != (short) (bytes - sizeof(packet.ip))) {
- DEBUG(LOG_INFO, "unrelated/bogus packet");
- return -1;
- }
-@@ -223,14 +223,14 @@
- /* verify the UDP checksum by replacing the header with a psuedo header */
- source = packet.ip.saddr;
- dest = packet.ip.daddr;
-- check = packet.udp.check;
-- packet.udp.check = 0;
-+ check = packet.udp.uh_sum;
-+ packet.udp.uh_sum = 0;
- memset(&packet.ip, 0, sizeof(packet.ip));
-
- packet.ip.protocol = IPPROTO_UDP;
- packet.ip.saddr = source;
- packet.ip.daddr = dest;
-- packet.ip.tot_len = packet.udp.len; /* cheat on the psuedo-header */
-+ packet.ip.tot_len = packet.udp.uh_ulen; /* cheat on the psuedo-header */
- if (check && check != checksum(&packet, bytes)) {
- DEBUG(LOG_ERR, "packet with bad UDP checksum received, ignoring");
- return -1;
-diff -ur ppp-2.4.7.orig/pppd/plugins/dhcp/dhcpd.h ppp-2.4.7/pppd/plugins/dhcp/dhcpd.h
---- ppp-2.4.7.orig/pppd/plugins/dhcp/dhcpd.h 2002-08-31 11:52:31.000000000 +0000
-+++ ppp-2.4.7/pppd/plugins/dhcp/dhcpd.h 2015-05-20 13:24:10.999978974 +0000
-@@ -4,6 +4,7 @@
-
- #include <netinet/ip.h>
- #include <netinet/udp.h>
-+#include <sys/types.h>
-
- #include "leases.h"
-
diff --git a/net-dialup/ppp/files/ppp-2.4.7-musl.patch b/net-dialup/ppp/files/ppp-2.4.7-musl.patch
deleted file mode 100644
index 8b75727a..00000000
--- a/net-dialup/ppp/files/ppp-2.4.7-musl.patch
+++ /dev/null
@@ -1,179 +0,0 @@
-diff -ur ppp-2.4.7.orig/include/linux/ppp_defs.h ppp-2.4.7/include/linux/ppp_defs.h
---- ppp-2.4.7.orig/include/linux/ppp_defs.h 2014-08-09 12:31:39.000000000 +0000
-+++ ppp-2.4.7/include/linux/ppp_defs.h 2015-05-20 12:38:46.739983089 +0000
-@@ -50,6 +50,10 @@
- #ifndef _PPP_DEFS_H_
- #define _PPP_DEFS_H_
-
-+#ifndef __P
-+# define __P(x) x
-+#endif
-+
- /*
- * The basic PPP frame.
- */
-diff -ur ppp-2.4.7.orig/include/net/ppp_defs.h ppp-2.4.7/include/net/ppp_defs.h
---- ppp-2.4.7.orig/include/net/ppp_defs.h 2014-08-09 12:31:39.000000000 +0000
-+++ ppp-2.4.7/include/net/ppp_defs.h 2015-05-20 12:38:46.739983089 +0000
-@@ -38,6 +38,8 @@
- #ifndef _PPP_DEFS_H_
- #define _PPP_DEFS_H_
-
-+#include <sys/time.h>
-+
- /*
- * The basic PPP frame.
- */
-diff -ur ppp-2.4.7.orig/pppd/Makefile.linux ppp-2.4.7/pppd/Makefile.linux
---- ppp-2.4.7.orig/pppd/Makefile.linux 2014-08-09 12:31:39.000000000 +0000
-+++ ppp-2.4.7/pppd/Makefile.linux 2015-05-20 12:38:46.739983089 +0000
-@@ -126,7 +126,7 @@
- endif
-
- ifdef USE_LIBUTIL
--CFLAGS += -DHAVE_LOGWTMP=1
-+#CFLAGS += -DHAVE_LOGWTMP=1
- LIBS += -lutil
- endif
-
-diff -ur ppp-2.4.7.orig/pppd/magic.h ppp-2.4.7/pppd/magic.h
---- ppp-2.4.7.orig/pppd/magic.h 2014-08-09 12:31:39.000000000 +0000
-+++ ppp-2.4.7/pppd/magic.h 2015-05-20 12:38:46.739983089 +0000
-@@ -42,6 +42,10 @@
- * $Id: magic.h,v 1.5 2003/06/11 23:56:26 paulus Exp $
- */
-
-+#ifndef __P
-+# define __P(x) x
-+#endif
-+
- void magic_init __P((void)); /* Initialize the magic number generator */
- u_int32_t magic __P((void)); /* Returns the next magic number */
-
-diff -ur ppp-2.4.7.orig/pppd/plugins/rp-pppoe/config.h ppp-2.4.7/pppd/plugins/rp-pppoe/config.h
---- ppp-2.4.7.orig/pppd/plugins/rp-pppoe/config.h 2014-08-09 12:31:39.000000000 +0000
-+++ ppp-2.4.7/pppd/plugins/rp-pppoe/config.h 2015-05-20 12:38:46.739983089 +0000
-@@ -101,9 +101,6 @@
- /* Define if you have the <netpacket/packet.h> header file. */
- #define HAVE_NETPACKET_PACKET_H 1
-
--/* Define if you have the <sys/cdefs.h> header file. */
--#define HAVE_SYS_CDEFS_H 1
--
- /* Define if you have the <sys/dlpi.h> header file. */
- /* #undef HAVE_SYS_DLPI_H */
-
-diff -ur ppp-2.4.7.orig/pppd/plugins/rp-pppoe/if.c ppp-2.4.7/pppd/plugins/rp-pppoe/if.c
---- ppp-2.4.7.orig/pppd/plugins/rp-pppoe/if.c 2014-08-09 12:31:39.000000000 +0000
-+++ ppp-2.4.7/pppd/plugins/rp-pppoe/if.c 2015-05-20 12:38:46.739983089 +0000
-@@ -30,10 +30,6 @@
- #include <linux/if_packet.h>
- #endif
-
--#ifdef HAVE_NET_ETHERNET_H
--#include <net/ethernet.h>
--#endif
--
- #ifdef HAVE_ASM_TYPES_H
- #include <asm/types.h>
- #endif
-diff -ur ppp-2.4.7.orig/pppd/plugins/rp-pppoe/plugin.c ppp-2.4.7/pppd/plugins/rp-pppoe/plugin.c
---- ppp-2.4.7.orig/pppd/plugins/rp-pppoe/plugin.c 2014-08-09 12:31:39.000000000 +0000
-+++ ppp-2.4.7/pppd/plugins/rp-pppoe/plugin.c 2015-05-20 12:38:46.739983089 +0000
-@@ -46,7 +46,6 @@
- #include <unistd.h>
- #include <fcntl.h>
- #include <signal.h>
--#include <net/ethernet.h>
- #include <net/if_arp.h>
- #include <linux/ppp_defs.h>
- #include <linux/if_pppox.h>
-diff -ur ppp-2.4.7.orig/pppd/plugins/rp-pppoe/pppoe-discovery.c ppp-2.4.7/pppd/plugins/rp-pppoe/pppoe-discovery.c
---- ppp-2.4.7.orig/pppd/plugins/rp-pppoe/pppoe-discovery.c 2014-08-09 12:31:39.000000000 +0000
-+++ ppp-2.4.7/pppd/plugins/rp-pppoe/pppoe-discovery.c 2015-05-20 12:38:46.739983089 +0000
-@@ -27,10 +27,6 @@
- #include <linux/if_packet.h>
- #endif
-
--#ifdef HAVE_NET_ETHERNET_H
--#include <net/ethernet.h>
--#endif
--
- #ifdef HAVE_ASM_TYPES_H
- #include <asm/types.h>
- #endif
-@@ -55,6 +51,8 @@
- exit(status);
- }
-
-+#define error(x...) fprintf(stderr, x)
-+
- /* Initialize frame types to RFC 2516 values. Some broken peers apparently
- use different frame types... sigh... */
-
-diff -ur ppp-2.4.7.orig/pppd/plugins/rp-pppoe/pppoe.h ppp-2.4.7/pppd/plugins/rp-pppoe/pppoe.h
---- ppp-2.4.7.orig/pppd/plugins/rp-pppoe/pppoe.h 2014-08-09 12:31:39.000000000 +0000
-+++ ppp-2.4.7/pppd/plugins/rp-pppoe/pppoe.h 2015-05-20 12:38:46.739983089 +0000
-@@ -39,10 +39,6 @@
- #error Unknown method for accessing raw Ethernet frames
- #endif
-
--#ifdef HAVE_SYS_CDEFS_H
--#include <sys/cdefs.h>
--#endif
--
- #ifdef HAVE_SYS_SOCKET_H
- #include <sys/socket.h>
- #endif
-@@ -86,19 +82,6 @@
-
- #include <netinet/in.h>
-
--#ifdef HAVE_NETINET_IF_ETHER_H
--#include <sys/types.h>
--
--#ifdef HAVE_SYS_SOCKET_H
--#include <sys/socket.h>
--#endif
--#ifndef HAVE_SYS_DLPI_H
--#include <netinet/if_ether.h>
--#endif
--#endif
--
--
--
- /* Ethernet frame types according to RFC 2516 */
- #define ETH_PPPOE_DISCOVERY 0x8863
- #define ETH_PPPOE_SESSION 0x8864
-diff -ur ppp-2.4.7.orig/pppd/sys-linux.c ppp-2.4.7/pppd/sys-linux.c
---- ppp-2.4.7.orig/pppd/sys-linux.c 2014-08-09 12:31:39.000000000 +0000
-+++ ppp-2.4.7/pppd/sys-linux.c 2015-05-20 12:39:38.269983011 +0000
-@@ -73,7 +73,7 @@
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <sys/time.h>
--#include <sys/errno.h>
-+#include <errno.h>
- #include <sys/file.h>
- #include <sys/stat.h>
- #include <sys/utsname.h>
-@@ -102,19 +102,11 @@
- #define MAX_ADDR_LEN 7
- #endif
-
--#if __GLIBC__ >= 2
- #include <asm/types.h> /* glibc 2 conflicts with linux/types.h */
- #include <net/if.h>
- #include <net/if_arp.h>
- #include <net/route.h>
- #include <netinet/if_ether.h>
--#else
--#include <linux/types.h>
--#include <linux/if.h>
--#include <linux/if_arp.h>
--#include <linux/route.h>
--#include <linux/if_ether.h>
--#endif
- #include <netinet/in.h>
- #include <arpa/inet.h>
-